Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-45703: Pimcore has a WordExport Authorization Bypass for Unauthorized Document Export

CVE-2026-45703 is a medium-severity missing authorization vulnerability in the PHP package pimcore/pimcore (CVSS 6.4), published 17 July 2026. It is fixed in 2026.1.3; earlier versions are affected. Exploiting it needs a low-privilege user account.

medium 6.4 published 2026-07-17 · updated 2026-07-22

Fixed in pimcore/pimcore 2026.1.3

This missing authorization issue affects pimcore/pimcore in 3 release lines: <= 11.5.16; >= 12.0.0-RC1, <= 12.3.6; >= 2026.1.0, < 2026.1.3. Upgrade to the fixed version for your release line (2026.1.3). The newest release, 2026.3.4, is not affected.

Affected versions
<= 11.5.16
>= 12.0.0-RC1, <= 12.3.6
>= 2026.1.0, < 2026.1.3
Fixed in
2026.1.3
Newest release
2026.3.4
Severity
Medium · CVSS 6.4
Type
Missing authorization check
CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-45703

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:L

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45703 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies. You need 2026.1.3 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^2026.1.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45703.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-45703 advisory

Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.17 (LTS) and 12.3.7, the WordExport export flow in bundles/WordExportBundle/src/Controller/TranslationController.php only checks the word_export feature permission and directly resolves attacker-controlled type/id input without enforcing view permission on page, snippet, email, or object elements, allowing a low-privileged backend user to export document content the user is not allowed to view. This issue is fixed in versions 11.5.17 (LTS) and 12.3.7.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45703. Advisory title: “Pimcore has a WordExport Authorization Bypass for Unauthorized Document Export”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit