Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-27461: Pimcore vulnerable to SQL injection via unsanitized filter value in Dependency Dao RLIKE clause

CVE-2026-27461 is a medium-severity SQL injection vulnerability in the PHP package pimcore/pimcore (CVSS 4.9), published 24 February 2026. It is fixed in 12.3.3; earlier versions are affected. Exploiting it needs an admin-level account.

medium 4.9 published 2026-02-24 · updated 2026-06-17

Fixed in pimcore/pimcore 12.3.3

This SQL injection issue affects pimcore/pimcore in 2 release lines: <= 11.5.14.1; >= 12.0.0, < 12.3.3. Upgrade to the fixed version for your release line (12.3.3). The newest release, 2026.3.4, is not affected.

Affected versions
<= 11.5.14.1
>= 12.0.0, < 12.3.3
Fixed in
12.3.3
Newest release
2026.3.4
Severity
Medium · CVSS 4.9
Type
SQL injection
CWE-89
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-27461

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-27461 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies. You need 12.3.3 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^12.3.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-27461.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-27461 advisory

Pimcore is an Open Source Data & Experience Management Platform. In versions up to and including 11.5.14.1 and 12.3.2, the filter query parameter in the dependency listing endpoints is JSON-decoded and the value field is concatenated directly into RLIKE clauses without sanitization or parameterized queries. Exploiting this issue requires admin authentication. An attacker with admin panel access can extract the full database including password hashes of other admin users. Version 12.3.3 contains a patch.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-27461. Advisory title: “Pimcore vulnerable to SQL injection via unsanitized filter value in Dependency Dao RLIKE clause”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit