pimcore/pimcore security advisory
CVE-2026-23494: Pimcore is Vulnerable to Broken Access Control: Missing Function Level Authorization on "Static Routes" Listing
CVE-2026-23494 is a medium-severity missing authorization vulnerability in the PHP package pimcore/pimcore (CVSS 6.5), published 15 January 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.
medium 6.5 published 2026-01-15 · updated 2026-06-17
- Affected versions
- <= 11.5.13
>= 12.0.0-RC1, <= 12.3 - Fixed in
- not stated
- Newest release
- 2026.3.4
- Severity
- Medium · CVSS 6.5
- Type
- Missing authorization check
CWE-284 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your pimcore/pimcore version affected?
Who can exploit CVE-2026-23494
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
How to fix CVE-2026-23494 in pimcore/pimcore
- Find the installed version:
composer show pimcore/pimcore. If you never required it yourself,composer why pimcore/pimcoreshows which package pulls it in. - Update it:
composer update pimcore/pimcore --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"pimcore/pimcore": "^2026.3.4"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-23494. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-23494 advisory
Pimcore is an Open Source Data & Experience Management Platform. Prior to 12.3.1 and 11.5.14, the application fails to enforce proper server-side authorization checks on the API endpoint responsible for reading or listing static routes. In Pimcore, static routes are custom URL patterns defined via the backend interface or the var/config/staticroutes.php file, including details like regex-based patterns, controllers, variables, and priorities. These routes are registered automatically through the PimcoreStaticRoutesBundle and integrated into the MVC routing system. Testing revealed that an authenticated backend user lacking explicit permissions was able to invoke the endpoint (e.g., GET /api/static-routes) and retrieve sensitive route configurations. This vulnerability is fixed in 12.3.1 and 11.5.14.
References
- GitHub advisory GHSA-m3r2-724c-pwgf github.com
- Pull request #18893 github.com
- Release v11.5.14 github.com
- Release v12.3.1 github.com
Other pimcore/pimcore advisories
- high CVE-2026-55416: Pimcore: SQL Injection in Custom Reports via Malicious Report Configuration 2026-09-10
- critical CVE-2026-55634: Pimcore Vulnerable to Remote Code Execution via DataObject Class-Definition Field Name 2026-08-28
- critical CVE-2026-55220: Pimcore Hotspotimage getDataFromResource() unrestricted Serialize::unserialize over object-store column (PHP Object Injection, CWE-502) 2026-08-28
- high CVE-2026-55072: Pimcore: ClassDefinition UID regex missing end anchor allows SQL injection via Block.php unquoted table name 2026-08-13
- high CVE-2026-11407: Pimcore CMS Twig Sandbox Bypass via SecurityPolicy checkMethodAllowed 2026-06-17
- high CVE-2026-5394: Pimcore Platform - SQL Injection in DataObject composite index handling during class definition import/save 2026-05-28
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.