Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-23493: Pimcore ENV Variables and Cookie Informations are exposed in http_error_log

CVE-2026-23493 is a high-severity information disclosure vulnerability in the PHP package pimcore/pimcore (CVSS 4.9), published 15 January 2026. The advisory does not name a fixed version. Exploiting it needs an admin-level account.

high 4.9 published 2026-01-15 · updated 2026-06-17

The advisory does not name a fixed version

This information disclosure issue affects pimcore/pimcore in 2 release lines: <= 11.5.13; >= 12.0.0-RC1, <= 12.3. The newest release (2026.3.4) is outside the affected range.

Affected versions
<= 11.5.13
>= 12.0.0-RC1, <= 12.3
Fixed in
not stated
Newest release
2026.3.4
Severity
High · CVSS 4.9
Type
Information disclosure
CWE-532
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-23493

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-23493 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^2026.3.4" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-23493.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for information disclosure issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-23493 advisory

Pimcore is an Open Source Data & Experience Management Platform. Prior to 12.3.1 and 11.5.14, the http_error_log file stores the $_COOKIE and $_SERVER variables, which means sensitive information such as database passwords, cookie session data, and other details can be accessed or recovered through the Pimcore backend. This vulnerability is fixed in 12.3.1 and 11.5.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-23493. Advisory title: “Pimcore ENV Variables and Cookie Informations are exposed in http_error_log”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit