Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-23492: Pimcore Has an Incomplete Patch for CVE-2023-30848

CVE-2026-23492 is a high-severity SQL injection vulnerability in the PHP package pimcore/pimcore (CVSS 4.9), published 14 January 2026. It is fixed in 12.3.1; earlier versions are affected. Exploiting it needs an admin-level account.

high 4.9 published 2026-01-14 · updated 2026-06-17

Fixed in pimcore/pimcore 12.3.1

This SQL injection issue affects pimcore/pimcore in 2 release lines: <= 11.5.13; >= 12.0.0-RC1, < 12.3.1. Upgrade to the fixed version for your release line (12.3.1). The newest release, 2026.3.4, is not affected.

Affected versions
<= 11.5.13
>= 12.0.0-RC1, < 12.3.1
Fixed in
12.3.1
Newest release
2026.3.4
Severity
High · CVSS 4.9
Type
SQL injection
CWE-89
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-23492

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-23492 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies. You need 12.3.1 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^12.3.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-23492.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

Although CVE-2023-30848 attempted to mitigate SQL injection by removing SQL comments (--) and catching syntax errors, the fix is insufficient.

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-23492 advisory

Pimcore is an Open Source Data & Experience Management Platform. Prior to 12.3.1 and 11.5.14, an incomplete SQL injection patch in the Admin Search Find API allows an authenticated attacker to perform blind SQL injection. Although CVE-2023-30848 attempted to mitigate SQL injection by removing SQL comments (--) and catching syntax errors, the fix is insufficient. Attackers can still inject SQL payloads that do not rely on comments and infer database information via blind techniques. This vulnerability affects the admin interface and can lead to database information disclosure. This vulnerability is fixed in 12.3.1 and 11.5.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-23492. Advisory title: “Pimcore Has an Incomplete Patch for CVE-2023-30848”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit