Plugins · subscribe-to-comments · data as of 2026-11-04
Is Subscribe to Comments safe? Known vulnerabilities and latest version
- Latest version
- 2.3.3
- Last updated
- 2026-10-06
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Subscribe to Comments allows commenters on an entry to subscribe to e-mail notifications for subsequent comments. — by Mark Jaquith
What to do
- Update to the latest version (2.3.3). Anything older than 2.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get subscribe-to-comments --field=version shows what you run; wp plugin update subscribe-to-comments updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.8 CVE-2026-91831 · published 2026-10-19
Security issue in Subscribe to Comments (2.3 up to (not including) 2.3.3)
- Affected
- 2.3 up to (not including) 2.3.3
- Fixed in
- 2.3.3
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Subscribe to Comments WordPress plugin before 2.3.3 does not sanitise newline characters from a notification sender-name setting before using it in e-mail headers, allowing users with Author-level access and above to inject arbitrary e-mail headers, such as a hidden Bcc, and to spoof the sender.
medium 6.5 CVE-2026-91830 · published 2026-10-16
Information disclosure in Subscribe to Comments (older than 2.3.3)
- Affected
- older than 2.3.3
- Fixed in
- 2.3.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Subscribe to Comments WordPress plugin before 2.3.3 does not sign or validate a cookie it trusts to identify a commenter, allowing unauthenticated attackers to disclose a subscriber's management key and silently alter that subscriber's subscriptions.
high 7.1 CVE-2026-91829 · published 2026-10-11
Reflected cross-site scripting (XSS) in Subscribe to Comments (older than 2.3.3)
- Affected
- older than 2.3.3
- Fixed in
- 2.3.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Subscribe to Comments WordPress plugin before 2.3.3 does not properly validate a parameter before reflecting it into a link target, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting via a crafted URL against anyone who clicks it, including administrators.
medium 5.9 CVE-2026-66706 · published 2026-08-06
Cross-site scripting (XSS) in Subscribe to Comments (2.3.1 and older)
- Affected
- 2.3.1 and older
- Fixed in
- 2.3.2 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Author Cross Site Scripting (XSS) in Subscribe to Comments <= 2.3.1 versions.
high 7.2 CVE-2015-10133 · published 2025-07-19
File inclusion in Subscribe to Comments (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.3 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Subscribe to Comments for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 2.1.2 via the Path to header value. This allows authenticated attackers, with administrative privileges and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. This same function can also be used to execute arbitrary PHP code.
NVD CVE-2015-10133Wordfence advisoryCode change (fix)advisories.dxw.compacketstormsecurity.comseclists.org
medium 6.1 CVE-2024-8792 · published 2024-10-30
Reflected cross-site scripting (XSS) in Subscribe to Comments (2.3 and older)
- Affected
- 2.3 and older
- Fixed in
- 2.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Subscribe to Comments plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.3. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-8792Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-06 — latest release on wordpress.org (2.3.3).
- 2026-10-19 — Security issue disclosed (CVE-2026-91831), fixed in 2.3.3.
- 2026-10-16 — Information disclosure disclosed (CVE-2026-91830), fixed in 2.3.3.
- 2026-10-11 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-91829), fixed in 2.3.3.
Get an email when Subscribe to Comments has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Subscribe to Comments (subscribe-to-comments) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/subscribe-to-comments (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/subscribe-to-comments"><img src="https://laskyr.com/plugins/subscribe-to-comments/badge.svg" alt="Subscribe to Comments vulnerability status"></a>