Skip to content
Laskyr

CVE-2026-91831: Subscribe to Comments vulnerability

low 3.8 published 2026-10-19

Fixed in Subscribe to Comments 2.3.3

Subscribe to Comments 2.3 up to (not including) 2.3.3 is affected by this security issue. Sites on 2.3.3 or newer are not affected; the latest release is 2.3.3.

Affected versions
2.3 up to (not including) 2.3.3
Fixed in
2.3.3
Latest version
2.3.3
Severity
Low · CVSS 3.8
Active installs
10,000+
Type
Security issue

What an attacker needs

CVSS vector (score by WPScan): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update Subscribe to Comments to 2.3.3 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Subscribe to Comments issue. With WP-CLI: wp plugin get subscribe-to-comments --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Subscribe to Comments WordPress plugin before 2.3.3 does not sanitise newline characters from a notification sender-name setting before using it in e-mail headers, allowing users with Author-level access and above to inject arbitrary e-mail headers, such as a hidden Bcc, and to spoof the sender.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-91831.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit