Skip to content
Laskyr

CVE-2026-91830: Subscribe to Comments information disclosure vulnerability

medium 6.5 published 2026-10-16

Fixed in Subscribe to Comments 2.3.3

Subscribe to Comments older than 2.3.3 is affected by this information disclosure issue. Sites on 2.3.3 or newer are not affected; the latest release is 2.3.3.

Affected versions
older than 2.3.3
Fixed in
2.3.3
Latest version
2.3.3
Severity
Medium · CVSS 6.5
Active installs
10,000+
Type
Information disclosure

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update Subscribe to Comments to 2.3.3 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Subscribe to Comments issue. With WP-CLI: wp plugin get subscribe-to-comments --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Subscribe to Comments WordPress plugin before 2.3.3 does not sign or validate a cookie it trusts to identify a commenter, allowing unauthenticated attackers to disclose a subscriber's management key and silently alter that subscriber's subscriptions.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-91830.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit