Plugins · fastcache-by-host-it · data as of 2026-11-04
Is Fastcache by Host.it safe? Known vulnerabilities and latest version
- Latest version
- 1.7.8
- Last updated
- 2026-10-22
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.0+
FastCache è un plugin WordPress per caching avanzato, CDN e ottimizzazione delle prestazioni, sviluppato e supportato interamente in Italia. — by Host.it
What to do
- Update to the latest version (1.7.8). Anything older than 1.7.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get fastcache-by-host-it --field=version shows what you run; wp plugin update fastcache-by-host-it updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-107763 · published 2026-10-17
Missing authorization check in Fastcache by Host.it (1.7.5 and older)
- Affected
- 1.7.5 and older
- Fixed in
- 1.7.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Fastcache by Host.it plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.7.5. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to add or remove the plugin's page-cache rewrite rules in the site's root .htaccess file.
NVD CVE-2026-107763Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2026-104021 · published 2026-10-10
Remote code execution in Fastcache by Host.it (1.7.4 and older)
- Affected
- 1.7.4 and older
- Fixed in
- 1.7.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Fastcache by Host.it plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 1.7.4 via the `fastcache_settings[cache_cookie_exclude][]` parameter. This is due to the plugin registering the `cache_cookie_exclude` setting via `register_setting()` without a `sanitize_callback`, while `buildSiteHtaccessRules()` applies only `trim()` to each cookie value before interpolating it directly into an Apache `RewriteCond` line — a normalization that strips surrounding whitespace but leaves embedded newlines intact, allowing an attacker to break out of the capture group and append arbitrary directives. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary Apache directives into the site's `.htaccess` file via `file_put_contents()`, enabling server-level configuration changes such as setting `php_value auto_prepend_file` to execute attacker-controlled PHP code on every request.
NVD CVE-2026-104021Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-22 — latest release on wordpress.org (1.7.8).
- 2026-10-17 — Missing authorization check disclosed (CVE-2026-107763), fixed in 1.7.6.
- 2026-10-10 — Remote code execution disclosed (CVE-2026-104021), fixed in 1.7.5.
Get an email when Fastcache by Host.it has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Fastcache by Host.it (fastcache-by-host-it) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/fastcache-by-host-it (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/fastcache-by-host-it"><img src="https://laskyr.com/plugins/fastcache-by-host-it/badge.svg" alt="Fastcache by Host.it vulnerability status"></a>