Skip to content
Laskyr

Plugins · acf-views · data as of 2026-11-04

Is Advanced Views safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.8)

As of 2026-11-04. 4 issues are on record for older versions; version 3.9.7 or newer fixes all of them that state a fix.

Latest version
3.9.8
Last updated
2026-10-22
Active installs
2,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Query, filter and display content dynamically - WooCommerce and CPT Grids, ACF Galleries, MetaBox Maps and more. — by WPLake

What to do

  1. Update to the latest version (3.9.8). Anything older than 3.9.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get acf-views --field=version shows what you run; wp plugin update acf-views updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-109995 · published 2026-10-27

Stored cross-site scripting (XSS) in Advanced Views (3.9.6 and older)

Affected
3.9.6 and older
Fixed in
3.9.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Views – Display Framework for Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.9.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable even against pending or unapproved comments, as the plugin's get_comment() lookup applies no approval-status filter, meaning a payload executes for any visitor loading an avf-layout block bound to the attacker's comment ID before the comment is ever reviewed.

NVD CVE-2026-109995Wordfence advisoryPlugin source

medium 6.5 CVE-2026-17580 · published 2026-08-01

Information disclosure in Advanced Views (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.9.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Views – Display Custom Fields (ACF, Pods, MetaBox), Posts, CPT and Woo Products anywhere in Gutenberg, Elementor, Divi, Beaver… plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.9.1 via the register_rest_routes. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive admin-authored editor content — including template markup, CSS code, JavaScript code, and PHP controller variables — for any Layout or Post Selection post on the site.

NVD CVE-2026-17580Wordfence advisoryCode change (fix)Plugin source

critical 9.9 CVE-2026-59543 · published 2026-07-23

Remote code execution in Advanced Views (3.8.11 and older)

Affected
3.8.11 and older
Fixed in
3.9.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Remote Code Execution (RCE) in Advanced Views <= 3.8.11 versions.

NVD CVE-2026-59543Patchstack advisory

high 8.8 CVE-2025-10380 · published 2025-09-23

Security issue in Advanced Views (3.7.19 and older)

Affected
3.7.19 and older
Fixed in
3.7.20 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Views – Display Posts, Custom Fields, and More plugin for WordPress is vulnerable to Server-Side Template Injection in all versions up to, and including, 3.7.19. This is due to insufficient input sanitization and lack of access control when processing custom Twig templates in the Model panel. This makes it possible for authenticated attackers, with author-level access or higher, to execute arbitrary PHP code and commands on the server.

NVD CVE-2025-10380Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Views vulnerability status badge
<a href="https://laskyr.com/plugins/acf-views"><img src="https://laskyr.com/plugins/acf-views/badge.svg" alt="Advanced Views vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit