Skip to content
Laskyr

CVE-2026-109995: Advanced Views stored cross-site scripting (XSS) vulnerability

high 7.2 published 2026-10-27 · updated 2026-10-29

Fixed in Advanced Views 3.9.7 (first release after the affected range)

Advanced Views 3.9.6 and older is affected by this stored XSS issue. Sites on 3.9.7 or newer are not affected; the latest release is 3.9.8.

Affected versions
3.9.6 and older
Fixed in
3.9.7 *
Latest version
3.9.8
Severity
High · CVSS 7.2
Active installs
2,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update Advanced Views to 3.9.7 or newer (the latest is 3.9.8): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Advanced Views issue. With WP-CLI: wp plugin get acf-views --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Advanced Views – Display Framework for Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.9.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable even against pending or unapproved comments, as the plugin's get_comment() lookup applies no approval-status filter, meaning a payload executes for any visitor loading an avf-layout block bound to the attacker's comment ID before the comment is ever reviewed.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-109995.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit