phpseclib/phpseclib security advisory
CVE-2026-55599: Phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority…
CVE-2026-55599 is a medium-severity SSRF vulnerability in the PHP package phpseclib/phpseclib (CVSS 5.8), published 22 June 2026. The advisory does not name a fixed version. It can be exploited without an account.
medium 5.8 published 2026-06-22 · updated 2026-06-26
- Affected versions
- >= 0.1.1, <= 1.0.29
>= 2.0.0, <= 2.0.54
>= 3.0.0, <= 3.0.53 - Fixed in
- not stated
- Newest release
- 4.0.3
- Severity
- Medium · CVSS 5.8
- Type
- Server-side request forgery (SSRF)
CWE-918 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your phpseclib/phpseclib version affected?
Who can exploit CVE-2026-55599
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
How to fix CVE-2026-55599 in phpseclib/phpseclib
- Find the installed version:
composer show phpseclib/phpseclib. If you never required it yourself,composer why phpseclib/phpseclibshows which package pulls it in. - Update it:
composer update phpseclib/phpseclib --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"phpseclib/phpseclib": "^4.0.3"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-55599. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Block outbound requests from the app server to private ranges and cloud metadata (169.254.169.254) at the firewall.
- Do not pass user-supplied URLs to the affected feature.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-55599 advisory
phpseclib is a PHP secure communications library. From 0.1.1 until 1.0.30, 2.0.55, and 3.0.54, when an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 169.254.169.254, and internal-only services. This is a server-side request forgery (SSRF) caused by an insecure default. This vulnerability is fixed in 1.0.30, 2.0.55, and 3.0.54.
References
- GitHub advisory GHSA-m557-wrgg-6rp4 github.com
Other phpseclib/phpseclib advisories
- medium CVE-2026-84308: Phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery 2026-09-08
- high CVE-2026-44167: Phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID() 2026-05-05
- low CVE-2026-40194: Phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals() 2026-04-10
- high CVE-2026-32935: Phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack 2026-03-19
- high CVE-2023-52892: Name confusion in x509 Subject Alternative Name fields 2024-06-28
- high CVE-2024-27354: Phpseclib a large prime can cause a denial of service 2024-03-02
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.