Skip to content
Laskyr

phpseclib/phpseclib security advisory

CVE-2026-32935: Phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

CVE-2026-32935 is a high-severity user enumeration vulnerability in the PHP package phpseclib/phpseclib (CVSS 5.9), published 20 March 2026. The advisory does not name a fixed version. It can be exploited without an account.

high 5.9 published 2026-03-20 · updated 2026-06-17

The advisory does not name a fixed version

This user enumeration issue affects phpseclib/phpseclib in 3 release lines: >= 0.1.1, <= 1.0.26; >= 2.0.0, <= 2.0.51; >= 3.0.0, <= 3.0.49. The newest release (4.0.3) is outside the affected range.

Affected versions
>= 0.1.1, <= 1.0.26
>= 2.0.0, <= 2.0.51
>= 3.0.0, <= 3.0.49
Fixed in
not stated
Newest release
4.0.3
Severity
High · CVSS 5.9
Type
User enumeration
CWE-208
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your phpseclib/phpseclib version affected?

Run composer show phpseclib/phpseclib in your project, then enter the version. We check it against this and every other known phpseclib/phpseclib advisory.

Who can exploit CVE-2026-32935

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of phpseclib/phpseclib. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-32935 in phpseclib/phpseclib

  1. Find the installed version: composer show phpseclib/phpseclib. If you never required it yourself, composer why phpseclib/phpseclib shows which package pulls it in.
  2. Update it: composer update phpseclib/phpseclib --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "phpseclib/phpseclib": "^4.0.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-32935.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for user enumeration issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-32935 advisory

phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-32935. Advisory title: “phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack”.

References

Other phpseclib/phpseclib advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit