Skip to content
Laskyr

phpseclib/phpseclib security advisory

CVE-2026-44167: Phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

CVE-2026-44167 is a high-severity denial of service vulnerability in the PHP package phpseclib/phpseclib (CVSS 7.5), published 12 May 2026. The advisory does not name a fixed version. It can be exploited without an account.

high 7.5 published 2026-05-12 · updated 2026-06-17

The advisory does not name a fixed version

This denial of service issue affects phpseclib/phpseclib in 3 release lines: >= 0.1.1, <= 1.0.28; >= 2.0.0, <= 2.0.53; >= 3.0.0, <= 3.0.51. The newest release (4.0.3) is outside the affected range.

Affected versions
>= 0.1.1, <= 1.0.28
>= 2.0.0, <= 2.0.53
>= 3.0.0, <= 3.0.51
Fixed in
not stated
Newest release
4.0.3
Severity
High · CVSS 7.5
Type
Denial of service
CWE-400
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your phpseclib/phpseclib version affected?

Run composer show phpseclib/phpseclib in your project, then enter the version. We check it against this and every other known phpseclib/phpseclib advisory.

Who can exploit CVE-2026-44167

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of phpseclib/phpseclib. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-44167 in phpseclib/phpseclib

  1. Find the installed version: composer show phpseclib/phpseclib. If you never required it yourself, composer why phpseclib/phpseclib shows which package pulls it in.
  2. Update it: composer update phpseclib/phpseclib --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "phpseclib/phpseclib": "^4.0.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-44167.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-44167 advisory

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-44167. Advisory title: “phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()”.

References

Other phpseclib/phpseclib advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit