Skip to content
Laskyr

backpack/crud security advisory

CVE-2026-54182: Laravel Backpack CRUD: OS command injection in Stats::makeCurlRequest via attacker-controlled Host header (pre-auth)

CVE-2026-54182 is a high-severity command injection vulnerability in the PHP package backpack/crud (CVSS 8.1), published 14 September 2026. It is fixed in 4.1.72, 5.6.2, 6.8.13 and 7.0.36, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 8.1 published 2026-09-14 · updated 2026-09-30

Fixed in backpack/crud 4.1.72, 5.6.2, 6.8.13 and 7.0.36

This command injection issue affects backpack/crud in 4 release lines: >= 4.1.0, < 4.1.72; >= 5.0.0, < 5.6.2; >= 6.0.0, < 6.8.13; >= 7.0.0, < 7.0.36. Upgrade to the fixed version for your release line (4.1.72, 5.6.2, 6.8.13 and 7.0.36). The newest release, 7.1.24, is not affected.

Affected versions
>= 4.1.0, < 4.1.72
>= 5.0.0, < 5.6.2
>= 6.0.0, < 6.8.13
>= 7.0.0, < 7.0.36
Fixed in
4.1.72, 5.6.2, 6.8.13, 7.0.36
Newest release
7.1.24
Severity
High · CVSS 8.1
Type
Command injection
CWE-20, CWE-78, CWE-116
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

The sources disagree on the fixed version. The CVE text names 4.1.70, while Packagist's advisory data, which composer audit checks, names 4.1.72 for the same release line. Upgrade to the higher of the two (4.1.72) to be safe by both.

Is your backpack/crud version affected?

Run composer show backpack/crud in your project, then enter the version. We check it against this and every other known backpack/crud advisory.

Who can exploit CVE-2026-54182

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of backpack/crud. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-54182 in backpack/crud

  1. Find the installed version: composer show backpack/crud. If you never required it yourself, composer why backpack/crud shows which package pulls it in.
  2. Update it: composer update backpack/crud --with-all-dependencies. You need the fixed version for your release line (4.1.72, 5.6.2, 6.8.13 and 7.0.36).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "backpack/crud": "^7.0.36" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-54182.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for command injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-54182 advisory

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Prior to 4.1.70, 5.6.2, 6.8.13, and 7.0.36, Backpack\CRUD\Stats::makeCurlRequest in src/Stats.php is reached from BackpackServiceProvider::boot() and constructs a shell command with a URL influenced by the HTTP Host header, which it passes to exec() without adequate shell neutralization. An unauthenticated attacker whose malformed Host value reaches PHP can inject operating-system commands when exec() and curl are available and the 1-in-100 random gate is reached. Repeated requests can reach the random gate. Successful exploitation executes commands as the web-server user, exposing environment secrets, files, and reachable services and permitting data modification or service disruption. Common reverse-proxy Host validation and hardened PHP configurations that disable exec() reduce reachability but do not correct the vulnerable construction. This issue is fixed in versions 4.1.70, 5.6.2, 6.8.13, and 7.0.36.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-54182. Advisory title: “Laravel Backpack CRUD: OS command injection in Stats::makeCurlRequest via attacker-controlled Host header (pre-auth)”.

References

Other backpack/crud advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit