Skip to content
Laskyr

backpack/crud security advisory

CVE-2026-54181: Laravel Backpack CRUD: Stored XSS in the color column — the @if($column['escaped']) branches are inverted

CVE-2026-54181 is a medium-severity stored XSS vulnerability in the PHP package backpack/crud (CVSS 5.4), published 14 September 2026. It is fixed in 6.8.14 and 7.0.38, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

medium 5.4 published 2026-09-14 · updated 2026-09-30

Fixed in backpack/crud 6.8.14 and 7.0.38

This stored XSS issue affects backpack/crud in 2 release lines: >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38. Upgrade to the fixed version for your release line (6.8.14 and 7.0.38). The newest release, 7.1.24, is not affected.

Affected versions
>= 6.0.0, < 6.8.14
>= 7.0.0, < 7.0.38
Fixed in
6.8.14, 7.0.38
Newest release
7.1.24
Severity
Medium · CVSS 5.4
Type
Stored cross-site scripting (XSS)
CWE-79, CWE-1023
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your backpack/crud version affected?

Run composer show backpack/crud in your project, then enter the version. We check it against this and every other known backpack/crud advisory.

Who can exploit CVE-2026-54181

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of backpack/crud. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-54181 in backpack/crud

  1. Find the installed version: composer show backpack/crud. If you never required it yourself, composer why backpack/crud shows which package pulls it in.
  2. Update it: composer update backpack/crud --with-all-dependencies. You need the fixed version for your release line (6.8.14 and 7.0.38).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "backpack/crud": "^7.0.38" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-54181.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-54181 advisory

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.38, src/resources/views/crud/columns/color.blade.php inverts the escaped and raw rendering branches controlled by $column['escaped'], which defaults to true, causing $column['text'] to be rendered unescaped by default. An attacker who can store an unsanitized value in a color column can execute script in the browser of a user who views the CRUD list, including an administrator, with access to the victim's session-backed application capabilities. Exploitation requires write access to the stored color value and a victim viewing the list. This issue is fixed in versions 6.8.14 and 7.0.38.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-54181. Advisory title: “Laravel Backpack CRUD: Stored XSS in the color column — the @if($column['escaped']) branches are inverted”.

References

Other backpack/crud advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit