Skip to content
Laskyr

backpack/crud security advisory

CVE-2026-54179: Laravel Backpack CRUD: SingleBase64Image accepts any base64 payload behind a data:image prefix — SVG-with-script lands on the public disk

CVE-2026-54179 is a medium-severity stored XSS vulnerability in the PHP package backpack/crud (CVSS 4.4), published 31 August 2026. It is fixed in 6.8.14 and 7.0.38, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

medium 4.4 published 2026-08-31 · updated 2026-09-08

Fixed in backpack/crud 6.8.14 and 7.0.38

This stored XSS issue affects backpack/crud in 2 release lines: >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38. Upgrade to the fixed version for your release line (6.8.14 and 7.0.38). The newest release, 7.1.24, is not affected.

Affected versions
>= 6.0.0, < 6.8.14
>= 7.0.0, < 7.0.38
Fixed in
6.8.14, 7.0.38
Newest release
7.1.24
Severity
Medium · CVSS 4.4
Type
Stored cross-site scripting (XSS)
CWE-79, CWE-434
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your backpack/crud version affected?

Run composer show backpack/crud in your project, then enter the version. We check it against this and every other known backpack/crud advisory.

Who can exploit CVE-2026-54179

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of backpack/crud. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-54179 in backpack/crud

  1. Find the installed version: composer show backpack/crud. If you never required it yourself, composer why backpack/crud shows which package pulls it in.
  2. Update it: composer update backpack/crud --with-all-dependencies. You need the fixed version for your release line (6.8.14 and 7.0.38).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "backpack/crud": "^7.0.38" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-54179.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-54179 advisory

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.37, the src/app/Library/Uploaders/SingleBase64Image.php methods SingleBase64Image::uploadFiles and SingleBase64Image::uploadRepeatableFiles, used by image fields through withFiles(), accept any data URI beginning with data:image without validating the declared MIME subtype or decoded bytes, while src/app/Library/Uploaders/Support/FileNameGenerator.php method FileNameGenerator::getExtensionFromFile applies mime_content_type() to the data URI instead of the decoded content. An authenticated administrator can therefore store arbitrary file content under an extensionless filename on the configured disk, which can cause stored cross-site scripting or other unintended behavior when the file is served and accessed. This issue is fixed in version 7.0.38 and 6.8.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-54179. Advisory title: “Laravel Backpack CRUD: SingleBase64Image accepts any base64 payload behind a data:image prefix — SVG-with-script lands on the public disk”.

References

Other backpack/crud advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit