Skip to content
Laskyr

statamic/cms security advisory

CVE-2026-49287: Statamic CMS's unsafe method invocation via collection sorting allows data destruction

CVE-2026-49287 is a high-severity security vulnerability in the PHP package statamic/cms (CVSS 7.4), published 19 June 2026. It is fixed in 5.73.23 and 6.20.0, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 7.4 published 2026-06-19 · updated 2026-10-25

Fixed in statamic/cms 5.73.23 and 6.20.0

This security issue affects statamic/cms in 2 release lines: < 5.73.23; >= 6.0.0, < 6.20.0. Upgrade to the fixed version for your release line (5.73.23 and 6.20.0). The newest release, 6.40.0, is not affected.

Affected versions
< 5.73.23
>= 6.0.0, < 6.20.0
Fixed in
5.73.23, 6.20.0
Newest release
6.40.0
Severity
High · CVSS 7.4
Type
Security issue
CWE-470
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your statamic/cms version affected?

Run composer show statamic/cms in your project, then enter the version. We check it against this and every other known statamic/cms advisory.

Who can exploit CVE-2026-49287

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

Your app is only exposed if it uses the affected part of statamic/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-49287 in statamic/cms

  1. Find the installed version: composer show statamic/cms. If you never required it yourself, composer why statamic/cms shows which package pulls it in.
  2. Update it: composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.73.23 and 6.20.0).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "statamic/cms": "^6.20.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-49287.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-49287 advisory

Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.23 and 6.20.0, the fix for CVE-2026-41175 was incomplete. It addressed the issue in the query builder, but the same protection was not applied to in-memory collection sorting. Manipulating sort parameters could result in the loss of content and assets. This requires a front-end template that passes request input into a tag's sort parameter. It is not exploitable by default — a template would need to be explicitly set up to sort by a visitor-controlled value. This has been fixed in 5.73.23 and 6.20.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-49287. Advisory title: “Statamic CMS's unsafe method invocation via collection sorting allows data destruction”.

References

Other statamic/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit