statamic/cms security advisory
CVE-2026-71434: Statamic: Missing file upload validation on frontend forms allows uploading disallowed file types
CVE-2026-71434 is a medium-severity arbitrary file upload vulnerability in the PHP package statamic/cms (CVSS 5.3), published 6 August 2026. It is fixed in 5.74.3 and 6.24.2, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 5.3 published 2026-08-06 · updated 2026-10-24
- Affected versions
- < 5.74.3
>= 6.0.0, < 6.24.2 - Fixed in
- 5.74.3, 6.24.2
- Newest release
- 6.40.0
- Severity
- Medium · CVSS 5.3
- Type
- Arbitrary file upload
CWE-434 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your statamic/cms version affected?
Who can exploit CVE-2026-71434
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
How to fix CVE-2026-71434 in statamic/cms
- Find the installed version:
composer show statamic/cms. If you never required it yourself,composer why statamic/cmsshows which package pulls it in. - Update it:
composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.74.3 and 6.24.2). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"statamic/cms": "^6.24.2"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-71434. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Rename uploaded files on the server instead of keeping the name the user sent, and allow only the extensions you expect.
- Store uploads outside the web root, or turn off PHP execution in the upload folder.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-71434 advisory
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.3 and 6.24.2, public frontend forms did not enforce the file upload restrictions that the Control Panel enforces, so an unauthenticated visitor could upload file types an administrator had intended to disallow through a form's assets or files field, and for assets fields, files could be stored on a public, web-accessible disk, though the application's global upload allowlist still blocked executable types such as .php and .html. This issue is fixed in versions 5.74.3 and 6.24.2.
References
- GitHub advisory GHSA-qhr7-v3xp-vw9m github.com
- Fix commit 8be7b6c github.com
- Pull request #14958 github.com
- Release v5.74.3 github.com
- Release v6.24.2 github.com
Other statamic/cms advisories
- medium CVE-2026-71435: Statamic: Stored Cross-Site Scripting in Automagic Form Notification Email Template 2026-08-06
- medium CVE-2026-64662: Statamic: Missing authorization on navigation endpoint allows disclosure of restricted entries 2026-08-06
- medium CVE-2026-64663: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction 2026-08-06
- high CVE-2026-64665: Statamic: Account takeover via OAuth email matching without email-verification check 2026-08-06
- medium CVE-2026-64664: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence 2026-08-06
- medium CVE-2026-71293: Statamic CMS exposes two-factor recovery codes through dynamic Antlers rendering 2026-08-05
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.