Skip to content
Laskyr

statamic/cms security advisory

CVE-2026-64664: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence

CVE-2026-64664 is a medium-severity missing authorization vulnerability in the PHP package statamic/cms (CVSS 4.3), published 6 August 2026. It is fixed in 5.74.1 and 6.24.0, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

medium 4.3 published 2026-08-06 · updated 2026-10-24

Fixed in statamic/cms 5.74.1 and 6.24.0

This missing authorization issue affects statamic/cms in 2 release lines: < 5.74.1; >= 6.0.0, < 6.24.0. Upgrade to the fixed version for your release line (5.74.1 and 6.24.0). The newest release, 6.40.0, is not affected.

Affected versions
< 5.74.1
>= 6.0.0, < 6.24.0
Fixed in
5.74.1, 6.24.0
Newest release
6.40.0
Severity
Medium · CVSS 4.3
Type
Missing authorization check
CWE-200, CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your statamic/cms version affected?

Run composer show statamic/cms in your project, then enter the version. We check it against this and every other known statamic/cms advisory.

Who can exploit CVE-2026-64664

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of statamic/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-64664 in statamic/cms

  1. Find the installed version: composer show statamic/cms. If you never required it yourself, composer why statamic/cms shows which package pulls it in.
  2. Update it: composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.74.1 and 6.24.0).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "statamic/cms": "^6.24.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-64664.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-64664 advisory

Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.1 and 6.24.0, an authenticated Control Panel user could use an endpoint intended for the user creation wizard to determine if a given email address belonged to an existing user, without having permission to view users, though the endpoint only exposed user existence and not any other user data. This issue is fixed in versions 5.74.1 and 6.24.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-64664. Advisory title: “Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence”.

References

Other statamic/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit