Skip to content
Laskyr

laravel/framework security advisory

CVE-2026-48019: Laravel CRLF injection in default email rule

CVE-2026-48019 is a high-severity header injection vulnerability in the PHP package laravel/framework (CVSS 8.9), published 4 September 2026. It is fixed in 12.60.0 and 13.10.0, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 8.9 published 2026-09-04 · updated 2026-09-10

Fixed in laravel/framework 12.60.0 and 13.10.0

This header injection issue affects laravel/framework in 2 release lines: >= 9.0.0, < 12.60.0; >= 13.0.0, < 13.10.0. Upgrade to the fixed version for your release line (12.60.0 and 13.10.0). The newest release, 13.40.0, is not affected.

Affected versions
>= 9.0.0, < 12.60.0
>= 13.0.0, < 13.10.0
Fixed in
12.60.0, 13.10.0
Newest release
13.40.0
Severity
High · CVSS 8.9
Type
Header injection
CWE-93
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your laravel/framework version affected?

Run composer show laravel/framework in your project, then enter the version. We check it against this and every other known laravel/framework advisory.

Who can exploit CVE-2026-48019

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L

Your app is only exposed if it uses the affected part of laravel/framework. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48019 in laravel/framework

  1. Find the installed version: composer show laravel/framework. If you never required it yourself, composer why laravel/framework shows which package pulls it in.
  2. Update it: composer update laravel/framework --with-all-dependencies. You need the fixed version for your release line (12.60.0 and 13.10.0).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "laravel/framework": "^13.10.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48019.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for header injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48019 advisory

Laravel is a web application framework. Prior to versions 12.60.0 and 13.10.0, a CRLF injection vulnerability in Laravel's email validation, in combination with how Symfony Mailer and Symfony Mime handle certain character sequences, may allow an unauthenticated attacker to interfere with outbound email processing in applications that send mail to user-supplied addresses. This issue has been patched in versions 12.60.0 and 13.10.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48019. Advisory title: “Laravel CRLF injection in default email rule”.

References

Other laravel/framework advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit