Skip to content
Laskyr

laravel/framework security advisory

CVE-2026-102279: Laravel: XSS in Debug Page Information

CVE-2026-102279 is a low-severity XSS vulnerability in the PHP package laravel/framework (CVSS 3.1), published 28 September 2026. It is fixed in 12.69.0 and 13.30.0, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 3.1 published 2026-09-28 · updated 2026-09-30

Fixed in laravel/framework 12.69.0 and 13.30.0

This XSS issue affects laravel/framework in 2 release lines: < 12.69.0; >= 13.0.0, < 13.30.0. Upgrade to the fixed version for your release line (12.69.0 and 13.30.0). The newest release, 13.40.0, is not affected.

Affected versions
< 12.69.0
>= 13.0.0, < 13.30.0
Fixed in
12.69.0, 13.30.0
Newest release
13.40.0
Severity
Low · CVSS 3.1
Type
Cross-site scripting (XSS)
CWE-80
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your laravel/framework version affected?

Run composer show laravel/framework in your project, then enter the version. We check it against this and every other known laravel/framework advisory.

Who can exploit CVE-2026-102279

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of laravel/framework. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-102279 in laravel/framework

  1. Find the installed version: composer show laravel/framework. If you never required it yourself, composer why laravel/framework shows which package pulls it in.
  2. Update it: composer update laravel/framework --with-all-dependencies. You need the fixed version for your release line (12.69.0 and 13.30.0).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "laravel/framework": "^13.30.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-102279.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-102279 advisory

Laravel is a web application framework. Prior to 12.69.0 and 13.30.0, Laravel exception debug pages with APP_DEBUG=true pass attacker-controlled input to a Tippy.js tooltip configured with allowHTML true, enabling DOM-based cross-site scripting when a user hovers over the tooltip. This issue is fixed in versions 12.69.0 and 13.30.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-102279. Advisory title: “Laravel: XSS in Debug Page Information”.

References

Other laravel/framework advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit