Skip to content
Laskyr

laravel/framework security advisory

CVE-2026-114509: Laravel TokenGuard authentication bypass through non-string API credentials

CVE-2026-114509 is a critical-severity authentication bypass vulnerability in the PHP package laravel/framework (CVSS 9.2), published 21 October 2026. It is fixed in 12.68.0 and 13.29.0, one per release line; earlier versions on each line are affected. It can be exploited without an account.

critical 9.2 published 2026-10-21 · updated 2026-10-28

Fixed in laravel/framework 12.68.0 and 13.29.0

This authentication bypass issue affects laravel/framework in 2 release lines: < 12.68.0; >= 13.0.0, < 13.29.0. Upgrade to the fixed version for your release line (12.68.0 and 13.29.0). The newest release, 13.40.0, is not affected.

Affected versions
< 12.68.0
>= 13.0.0, < 13.29.0
Fixed in
12.68.0, 13.29.0
Newest release
13.40.0
Severity
Critical · CVSS 9.2
Type
Authentication bypass
CWE-287, CWE-1287
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your laravel/framework version affected?

Run composer show laravel/framework in your project, then enter the version. We check it against this and every other known laravel/framework advisory.

Who can exploit CVE-2026-114509

CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of laravel/framework. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-114509 in laravel/framework

  1. Find the installed version: composer show laravel/framework. If you never required it yourself, composer why laravel/framework shows which package pulls it in.
  2. Update it: composer update laravel/framework --with-all-dependencies. You need the fixed version for your release line (12.68.0 and 13.29.0).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "laravel/framework": "^13.29.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-114509.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for authentication bypass issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-114509 advisory

Laravel is a web application framework. Prior to 12.68.0 and 13.29.0, TokenGuard configured as a standard token-based API guard does not reject a crafted non-string credential. Under affected MySQL or MariaDB configurations, the authentication lookup can match an unintended existing user, allowing an unauthenticated attacker to bypass authentication and take over an account on routes protected by TokenGuard. This issue is fixed in versions 12.68.0 and 13.29.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-114509. Advisory title: “Laravel TokenGuard authentication bypass through non-string API credentials”.

References

Other laravel/framework advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit