shopware/core security advisory
CVE-2026-48014: Shopware: Admin API ACL Bypass in Order State Transition Endpoints
CVE-2026-48014 is a medium-severity missing authorization vulnerability in the PHP package shopware/core (CVSS 6.5), published 17 July 2026. It is fixed in 6.6.10.18 and 6.7.10.1, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
medium 6.5 published 2026-07-17 · updated 2026-07-21
- Affected versions
- < 6.6.10.18
>= 6.7.0.0, < 6.7.10.1 - Fixed in
- 6.6.10.18, 6.7.10.1
- Newest release
- 6.7.16.0
- Severity
- Medium · CVSS 6.5
- Type
- Missing authorization check
CWE-862 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your shopware/core version affected?
Who can exploit CVE-2026-48014
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
How to fix CVE-2026-48014 in shopware/core
- Find the installed version:
composer show shopware/core. If you never required it yourself,composer why shopware/coreshows which package pulls it in. - Update it:
composer update shopware/core --with-all-dependencies. You need the fixed version for your release line (6.6.10.18 and 6.7.10.1). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"shopware/core": "^6.7.10.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-48014. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-48014 advisory
Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, the order state transition features /api/_action/order/{orderId}/state/{transition} and similar transaction and delivery transition routes in src/Core/Checkout/Order/Api/OrderActionController.php do not declare PlatformRequest::ATTRIBUTE_ACL or perform an explicit privilege check, so AclAnnotationValidator exits when route ACL metadata is absent and low-privileged users without order:update, order_transaction:update, or order_delivery:update can trigger StateMachineRegistry::transition() writes in SYSTEM_SCOPE. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.
References
- GitHub advisory GHSA-f8q6-3g5w-jjr6 github.com
- Fix commit 86dff24 github.com
- Fix commit 9f15fae github.com
- Release v6.6.10.18 github.com
- Release v6.7.10.1 github.com
Other shopware/core advisories
- medium CVE-2026-48013: Shopware: SSRF in Media External-Link Endpoint Bypasses IP Validation 2026-06-04
- medium CVE-2026-48015: Shopware: Stored XSS via SVG file upload — no SVG sanitization 2026-06-04
- medium CVE-2026-48016: Shopware: Unauthorized Payment Trigger for Foreign Orders via /store-api/handle-payment 2026-06-04
- medium CVE-2026-48012: Shopware SSO referer trust leading to an arbitrary redirect target 2026-06-04
- low CVE-2026-48011: Shopware: Timing-attack on admin panel allowing enumeration of administrator usernames 2026-06-04
- medium CVE-2026-48010: Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts 2026-06-04
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.