Skip to content
Laskyr

shopware/core security advisory

CVE-2026-48010: Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts

CVE-2026-48010 is a medium-severity privilege escalation vulnerability in the PHP package shopware/core (CVSS 6.5), published 17 July 2026. It is fixed in 6.6.10.18 and 6.7.10.1, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.

medium 6.5 published 2026-07-17 · updated 2026-07-18

Fixed in shopware/core 6.6.10.18 and 6.7.10.1

This privilege escalation issue affects shopware/core in 2 release lines: < 6.6.10.18; >= 6.7.0.0, < 6.7.10.1. Upgrade to the fixed version for your release line (6.6.10.18 and 6.7.10.1). The newest release, 6.7.16.0, is not affected.

Affected versions
< 6.6.10.18
>= 6.7.0.0, < 6.7.10.1
Fixed in
6.6.10.18, 6.7.10.1
Newest release
6.7.16.0
Severity
Medium · CVSS 6.5
Type
Privilege escalation
CWE-269
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your shopware/core version affected?

Run composer show shopware/core in your project, then enter the version. We check it against this and every other known shopware/core advisory.

Who can exploit CVE-2026-48010

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N

Your app is only exposed if it uses the affected part of shopware/core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48010 in shopware/core

  1. Find the installed version: composer show shopware/core. If you never required it yourself, composer why shopware/core shows which package pulls it in.
  2. Update it: composer update shopware/core --with-all-dependencies. You need the fixed version for your release line (6.6.10.18 and 6.7.10.1).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "shopware/core": "^6.7.10.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48010.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for privilege escalation issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48010 advisory

Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, UserController::upsertUser() in src/Core/Framework/Api/Controller/UserController.php writes raw user data in SYSTEM_SCOPE without filtering the admin field, so a non-admin API user with user:create or user:update ACL permission can set admin: true on new or existing users; IntegrationController::upsertIntegration() contains an isAdmin() check for the same field, but UserController was missing this check. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48010. Advisory title: “Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts”.

References

Other shopware/core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit