Skip to content
Laskyr

shopware/core security advisory

CVE-2026-48011: Shopware: Timing-attack on admin panel allowing enumeration of administrator usernames

CVE-2026-48011 is a low-severity user enumeration vulnerability in the PHP package shopware/core (CVSS 3.7), published 10 June 2026. It is fixed in 6.6.10.18 and 6.7.10.1, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 3.7 published 2026-06-10 · updated 2026-07-23

Fixed in shopware/core 6.6.10.18 and 6.7.10.1

This user enumeration issue affects shopware/core in 2 release lines: < 6.6.10.18; >= 6.7.0.0, < 6.7.10.1. Upgrade to the fixed version for your release line (6.6.10.18 and 6.7.10.1). The newest release, 6.7.16.0, is not affected.

Affected versions
< 6.6.10.18
>= 6.7.0.0, < 6.7.10.1
Fixed in
6.6.10.18, 6.7.10.1
Newest release
6.7.16.0
Severity
Low · CVSS 3.7
Type
User enumeration
CWE-208
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your shopware/core version affected?

Run composer show shopware/core in your project, then enter the version. We check it against this and every other known shopware/core advisory.

Who can exploit CVE-2026-48011

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of shopware/core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48011 in shopware/core

  1. Find the installed version: composer show shopware/core. If you never required it yourself, composer why shopware/core shows which package pulls it in.
  2. Update it: composer update shopware/core --with-all-dependencies. You need the fixed version for your release line (6.6.10.18 and 6.7.10.1).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "shopware/core": "^6.7.10.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48011.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for user enumeration issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48011 advisory

Shopware is an open commerce platform. Prior to versions 6.6.10.18 and 6.7.10.1, an attacker is able to enumerate the usernames of administrator users by performing a timing attack. Versions 6.6.10.18 and 6.7.10.1 fix the issue.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48011. Advisory title: “Shopware: Timing-attack on admin panel allowing enumeration of administrator usernames”.

References

Other shopware/core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit