Skip to content
Laskyr

symfony/symfony security advisory

CVE-2026-45756: JsonPath Evaluates Attacker-Controlled Regular Expressions in match()/search() Without Limits: ReDoS in symfony/symfony

CVE-2026-45756 is a low-severity denial of service vulnerability in the PHP package symfony/symfony (CVSS 7.5), published 14 July 2026. It is fixed in 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 7.5 published 2026-07-14 · updated 2026-07-21

Fixed in symfony/symfony 7.4.12 and 8.0.12

This denial of service issue affects symfony/symfony in 2 release lines: >= 7.3.0, < 7.4.12; >= 8.0.0, < 8.0.12. Upgrade to the fixed version for your release line (7.4.12 and 8.0.12). The newest release, 8.1.10, is not affected.

Affected versions
>= 7.3.0, < 7.4.12
>= 8.0.0, < 8.0.12
Fixed in
7.4.12, 8.0.12
Newest release
8.1.10
Severity
Low · CVSS 7.5
Type
Denial of service
CWE-400, CWE-1333
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your symfony/symfony version affected?

Run composer show symfony/symfony in your project, then enter the version. We check it against this and every other known symfony/symfony advisory.

Who can exploit CVE-2026-45756

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of symfony/symfony. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45756 in symfony/symfony

  1. Find the installed version: composer show symfony/symfony. If you never required it yourself, composer why symfony/symfony shows which package pulls it in.
  2. Update it: composer update symfony/symfony --with-all-dependencies. You need the fixed version for your release line (7.4.12 and 8.0.12).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/symfony": "^8.0.12" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45756.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-45756 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 7.3.0-BETA1 until 7.4.12 and 8.0.12, the JsonPath component compiles attacker-controlled match() and search() filter patterns directly into preg_match() without a length cap, i-regexp restriction, or bounded backtracking, allowing catastrophic-backtracking expressions to pin worker CPU and cause denial of service. This issue is fixed in versions 7.4.12 and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45756. Advisory title: “CVE-2026-45756: JsonPath Evaluates Attacker-Controlled Regular Expressions in match()/search() Without Limits: ReDoS”.

References

Other symfony/symfony advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit