Skip to content
Laskyr

symfony/symfony security advisory

CVE-2026-45070: Email Header Injection via Non-Token Characters in Mime Parameter Names in symfony/symfony

CVE-2026-45070 is a medium-severity header injection vulnerability in the PHP package symfony/symfony (CVSS 6.5), published 14 July 2026. It is fixed in 5.4.55, 6.4.49, 7.4.22 and 8.1.10, one per release line; earlier versions on each line are affected. It can be exploited without an account.

medium 6.5 published 2026-07-14 · updated 2026-07-16

Fixed in symfony/symfony 5.4.55, 6.4.49, 7.4.22 and 8.1.10

This header injection issue affects symfony/symfony in 4 release lines: >= 2.0.0, < 5.4.55; >= 6.0.0, < 6.4.49; >= 7.0.0, < 7.4.22; >= 8.0.0, < 8.1.10. Upgrade to the fixed version for your release line (5.4.55, 6.4.49, 7.4.22 and 8.1.10). The newest release, 8.1.10, is not affected.

Affected versions
>= 2.0.0, < 5.4.55
>= 6.0.0, < 6.4.49
>= 7.0.0, < 7.4.22
>= 8.0.0, < 8.1.10
Fixed in
5.4.55, 6.4.49, 7.4.22, 8.1.10
Newest release
8.1.10
Severity
Medium · CVSS 6.5
Type
Header injection
CWE-93
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

The sources disagree on the fixed version. The CVE text names 5.4.52, 6.4.40 and 7.4.12, while Packagist's advisory data, which composer audit checks, names 5.4.55, 6.4.49 and 7.4.22 for the same release lines. Upgrade to the higher of the two (5.4.55, 6.4.49 and 7.4.22) to be safe by both.

Is your symfony/symfony version affected?

Run composer show symfony/symfony in your project, then enter the version. We check it against this and every other known symfony/symfony advisory.

Who can exploit CVE-2026-45070

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of symfony/symfony. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45070 in symfony/symfony

  1. Find the installed version: composer show symfony/symfony. If you never required it yourself, composer why symfony/symfony shows which package pulls it in.
  2. Update it: composer update symfony/symfony --with-all-dependencies. You need the fixed version for your release line (5.4.55, 6.4.49, 7.4.22 and 8.1.10).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/symfony": "^8.1.10" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45070.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for header injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-45070 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Mime\Header\ParameterizedHeader validates and encodes parameter values but emits parameter names verbatim, allowing a caller that derives a parameter name from untrusted input to include CRLF or other non-token bytes and inject additional headers into rendered structured mail headers such as Content-Type or Content-Disposition. This issue is reported as fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45070. Advisory title: “CVE-2026-45070: Email Header Injection via Non-Token Characters in Mime Parameter Names”.

References

Other symfony/symfony advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit