Skip to content
Laskyr

symfony/symfony security advisory

CVE-2026-109449: Unbounded Nesting in the Expression Parser Lets Untrusted Expressions Crash the Process in symfony/symfony

CVE-2026-109449 is a high-severity security vulnerability in the PHP package symfony/symfony (CVSS 8.7), published 15 October 2026. It is fixed in 5.4.54, 6.4.48, 7.4.21 and 8.1.9, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 8.7 published 2026-10-15 · updated 2026-10-16

Fixed in symfony/symfony 5.4.54, 6.4.48, 7.4.21 and 8.1.9

This security issue affects symfony/symfony in 4 release lines: >= 2.4.0, < 5.4.54; >= 6.0.0, < 6.4.48; >= 7.0.0, < 7.4.21; >= 8.0.0, < 8.1.9. Upgrade to the fixed version for your release line (5.4.54, 6.4.48, 7.4.21 and 8.1.9). The newest release, 8.1.10, is not affected.

Affected versions
>= 2.4.0, < 5.4.54
>= 6.0.0, < 6.4.48
>= 7.0.0, < 7.4.21
>= 8.0.0, < 8.1.9
Fixed in
5.4.54, 6.4.48, 7.4.21, 8.1.9
Newest release
8.1.10
Severity
High · CVSS 8.7
Type
Security issue
CWE-674
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your symfony/symfony version affected?

Run composer show symfony/symfony in your project, then enter the version. We check it against this and every other known symfony/symfony advisory.

Who can exploit CVE-2026-109449

CVSS vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of symfony/symfony. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-109449 in symfony/symfony

  1. Find the installed version: composer show symfony/symfony. If you never required it yourself, composer why symfony/symfony shows which package pulls it in.
  2. Update it: composer update symfony/symfony --with-all-dependencies. You need the fixed version for your release line (5.4.54, 6.4.48, 7.4.21 and 8.1.9).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/symfony": "^8.1.9" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-109449.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-109449 advisory

In Symfony Expression Language versions prior to 5.4.54, 6.4.48, 7.4.21, and 8.1.9, the parser of the ExpressionLanguage component built its node tree with no bound on its depth. An expression made of tens of thousands of nested unary operators, array literals, binary operators or property accesses crashed the PHP process, while the tree was being freed. #[Assert\ExpressionSyntax] passes the validated value to ExpressionLanguage::lint(), so an application validating expressions written by its users could be crashed by a single request, and so could any code parsing untrusted expressions. This issue affects symfony/expression-language through v5.4.53, v6.0.0-BETA1 through v6.4.47, v7.0.0-BETA1 through v7.4.20, and v8.0.0-BETA1 through v8.1.8.

Description from the CVE record, via the NVD entry for CVE-2026-109449. Advisory title: “CVE-2026-109449: Unbounded Nesting in the Expression Parser Lets Untrusted Expressions Crash the Process”.

References

Other symfony/symfony advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit