statamic/cms security advisory
CVE-2026-45660: Statamic CMS: Server-Side Request Forgery via Glide
CVE-2026-45660 is a medium-severity SSRF vulnerability in the PHP package statamic/cms (CVSS 5.4), published 29 May 2026. It is fixed in 5.73.22 and 6.18.1, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 5.4 published 2026-05-29 · updated 2026-07-22
- Affected versions
- < 5.73.22
>= 6.0.0-alpha.1, < 6.18.1 - Fixed in
- 5.73.22, 6.18.1
- Newest release
- 6.40.0
- Severity
- Medium · CVSS 5.4
- Type
- Server-side request forgery (SSRF)
CWE-918 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your statamic/cms version affected?
Who can exploit CVE-2026-45660
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
How to fix CVE-2026-45660 in statamic/cms
- Find the installed version:
composer show statamic/cms. If you never required it yourself,composer why statamic/cmsshows which package pulls it in. - Update it:
composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.73.22 and 6.18.1). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"statamic/cms": "^6.18.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-45660. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Block outbound requests from the app server to private ranges and cloud metadata (169.254.169.254) at the firewall.
- Do not pass user-supplied URLs to the affected feature.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-45660 advisory
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.22 and 6.18.1, the Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. This vulnerability is fixed in 5.73.22 and 6.18.1.
References
- GitHub advisory GHSA-pf9c-ch8r-2958 github.com
Other statamic/cms advisories
- medium CVE-2026-71435: Statamic: Stored Cross-Site Scripting in Automagic Form Notification Email Template 2026-08-06
- medium CVE-2026-71434: Statamic: Missing file upload validation on frontend forms allows uploading disallowed file types 2026-08-06
- medium CVE-2026-64662: Statamic: Missing authorization on navigation endpoint allows disclosure of restricted entries 2026-08-06
- medium CVE-2026-64663: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction 2026-08-06
- high CVE-2026-64665: Statamic: Account takeover via OAuth email matching without email-verification check 2026-08-06
- medium CVE-2026-64664: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.