symfony/symfony security advisory
CVE-2026-45073: SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix in symfony/symfony
CVE-2026-45073 is a medium-severity SQL injection vulnerability in the PHP package symfony/symfony (CVSS 7.3), published 14 July 2026. It is fixed in 5.4.52, 6.4.40, 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 7.3 published 2026-07-14 · updated 2026-10-24
- Affected versions
- >= 2.0.0, < 5.4.52
>= 6.0.0, < 6.4.40
>= 7.0.0, < 7.4.12
>= 8.0.0, < 8.0.12 - Fixed in
- 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Newest release
- 8.1.10
- Severity
- Medium · CVSS 7.3
- Type
- SQL injection
CWE-89 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your symfony/symfony version affected?
Who can exploit CVE-2026-45073
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
How to fix CVE-2026-45073 in symfony/symfony
- Find the installed version:
composer show symfony/symfony. If you never required it yourself,composer why symfony/symfonyshows which package pulls it in. - Update it:
composer update symfony/symfony --with-all-dependencies. You need the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/symfony": "^8.0.12"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-45073. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Make sure user input never reaches the affected query builder or ORM method unvalidated; allow-list column and sort names.
- Give the app's database user only the permissions it needs.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-45073 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, PdoAdapter::doClear() builds a DELETE statement using a namespace derived from the caller-supplied $prefix without binding or escaping it, allowing a caller able to influence $prefix to break out of the LIKE literal and alter query semantics or deletion scope. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
References
- GitHub security advisory GHSA-6qh9-h6wf-jgqc github.com
- Symfony security advisory symfony.com
- Fix commit ec50b79 github.com
- Release v5.4.52 github.com
- Release v6.4.40 github.com
- Release v7.4.12 github.com
- Release v8.0.12 github.com
Other symfony/symfony advisories
- medium CVE-2026-45070: Email Header Injection via Non-Token Characters in Mime Parameter Names 2026-10-28
- CVE-2026-109449: Unbounded Nesting in the Expression Parser Lets Untrusted Expressions Crash the Process 2026-10-14
- high CVE-2026-108082: ReDoS in HeaderUtils::split() Reachable Through the Cache-Control Request Header 2026-09-15
- high CVE-2026-109413: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process 2026-08-30
- medium CVE-2026-47767: SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch 2026-06-09
- medium CVE-2026-48747: Mailomat Mailer Webhook Parser Reads the HMAC Algorithm from the Request: Signature Algorithm Downgrade 2026-05-26
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.