statamic/cms security advisory
CVE-2026-33886: Statamic's sensitive configuration values are exposed to content editors via Antlers-enabled fields
CVE-2026-33886 is a medium-severity information disclosure vulnerability in the PHP package statamic/cms (CVSS 6.5), published 27 March 2026. It is fixed in 5.73.16 and 6.7.2, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
medium 6.5 published 2026-03-27 · updated 2026-10-26
- Affected versions
- >= 5.73.12, < 5.73.16
>= 6.5.0, < 6.7.2 - Fixed in
- 5.73.16, 6.7.2
- Newest release
- 6.40.0
- Severity
- Medium · CVSS 6.5
- Type
- Information disclosure
CWE-200 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your statamic/cms version affected?
Who can exploit CVE-2026-33886
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
How to fix CVE-2026-33886 in statamic/cms
- Find the installed version:
composer show statamic/cms. If you never required it yourself,composer why statamic/cmsshows which package pulls it in. - Update it:
composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.73.16 and 6.7.2). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"statamic/cms": "^6.7.2"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-33886. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Make sure APP_DEBUG (or your framework's debug mode) is off in production and error pages show no stack traces.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-33886 advisory
Statamic is a Laravel and Git powered content management system (CMS). Starting in version 5.7.12 and prior to versions 5.73.16 and 6.7.2, a control panel user with access to Antlers-enabled fields could access sensitive application configuration values by inserting config variables into their content. This has been fixed in 5.73.16 and 6.7.2.
References
- GitHub advisory GHSA-gcqf-5x9f-hq7f github.com
Other statamic/cms advisories
- medium CVE-2026-71435: Statamic: Stored Cross-Site Scripting in Automagic Form Notification Email Template 2026-08-06
- medium CVE-2026-71434: Statamic: Missing file upload validation on frontend forms allows uploading disallowed file types 2026-08-06
- medium CVE-2026-64662: Statamic: Missing authorization on navigation endpoint allows disclosure of restricted entries 2026-08-06
- medium CVE-2026-64663: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction 2026-08-06
- high CVE-2026-64665: Statamic: Account takeover via OAuth email matching without email-verification check 2026-08-06
- medium CVE-2026-64664: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.