Skip to content
Laskyr

statamic/cms security advisory

CVE-2026-32612: Statamic vulnerable to privilege escalation via stored cross-site scripting

CVE-2026-32612 is a medium-severity stored XSS vulnerability in the PHP package statamic/cms (CVSS 5.4), published 13 March 2026. It is fixed in 6.6.2; earlier versions are affected. Exploiting it needs a low-privilege user account.

medium 5.4 published 2026-03-13 · updated 2026-06-17

Fixed in statamic/cms 6.6.2

This stored XSS issue affects statamic/cms versions >= 6.0.0, < 6.6.2. Upgrade to the fixed version for your release line (6.6.2). The newest release, 6.40.0, is not affected.

Affected versions
>= 6.0.0, < 6.6.2
Fixed in
6.6.2
Newest release
6.40.0
Severity
Medium · CVSS 5.4
Type
Stored cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your statamic/cms version affected?

Run composer show statamic/cms in your project, then enter the version. We check it against this and every other known statamic/cms advisory.

Who can exploit CVE-2026-32612

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of statamic/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-32612 in statamic/cms

  1. Find the installed version: composer show statamic/cms. If you never required it yourself, composer why statamic/cms shows which package pulls it in.
  2. Update it: composer update statamic/cms --with-all-dependencies. You need 6.6.2 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "statamic/cms": "^6.6.2" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-32612.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-32612 advisory

Statamic is a Laravel and Git powered content management system (CMS). Prior to 6.6.2, stored XSS in the control panel color mode preference allows authenticated users with control panel access to inject malicious JavaScript that executes when a higher-privileged user impersonates their account. This has been fixed in 6.6.2.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-32612. Advisory title: “Statamic vulnerable to privilege escalation via stored cross-site scripting”.

References

Other statamic/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit