statamic/cms security advisory
CVE-2026-28425: Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs
CVE-2026-28425 is a high-severity remote code execution vulnerability in the PHP package statamic/cms (CVSS 8.0), published 27 February 2026. It is fixed in 5.73.16 and 6.7.2, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
high 8.0 published 2026-02-27 · updated 2026-06-17
- Affected versions
- < 5.73.16
>= 6.0.0-alpha.1, < 6.7.2 - Fixed in
- 5.73.16, 6.7.2
- Newest release
- 6.40.0
- Severity
- High · CVSS 8.0
- Type
- Remote code execution
CWE-94 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your statamic/cms version affected?
Who can exploit CVE-2026-28425
- Access: A normal, low-privilege user account in the app.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
How to fix CVE-2026-28425 in statamic/cms
- Find the installed version:
composer show statamic/cms. If you never required it yourself,composer why statamic/cmsshows which package pulls it in. - Update it:
composer update statamic/cms --with-all-dependencies. You need the fixed version for your release line (5.73.16 and 6.7.2). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"statamic/cms": "^6.7.2"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-28425. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Never pass user-controlled data to unserialize() or to template rendering, and restrict who can edit templates or settings.
- Put a web application firewall in front of the app and watch for new PHP files or admin users.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-28425 advisory
Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. This has been fixed in 5.73.16 and 6.7.2. Users of addons that depend on Statamic should ensure that after updating they are running a patched Statamic version.
References
- GitHub advisory GHSA-cpv7-q2wx-m8rw github.com
- Release v5.73.11 github.com
- Release v6.4.0 github.com
Other statamic/cms advisories
- medium CVE-2026-71435: Statamic: Stored Cross-Site Scripting in Automagic Form Notification Email Template 2026-08-06
- medium CVE-2026-71434: Statamic: Missing file upload validation on frontend forms allows uploading disallowed file types 2026-08-06
- medium CVE-2026-64662: Statamic: Missing authorization on navigation endpoint allows disclosure of restricted entries 2026-08-06
- medium CVE-2026-64663: Statamic: Unsafe method invocation via Antlers template resolution allows data destruction 2026-08-06
- high CVE-2026-64665: Statamic: Account takeover via OAuth email matching without email-verification check 2026-08-06
- medium CVE-2026-64664: Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existence 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.