shopware/core security advisory
CVE-2026-23498: Shopware Has Improper Control of Generation of Code in Twig rendered views
CVE-2026-23498 is a high-severity remote code execution vulnerability in the PHP package shopware/core (CVSS 7.2), published 14 January 2026. It is fixed in 6.7.6.1; earlier versions are affected. Exploiting it needs an admin-level account.
high 7.2 published 2026-01-14 · updated 2026-06-17
- Affected versions
- >= 6.7.0.0, < 6.7.6.1
- Fixed in
- 6.7.6.1
- Newest release
- 6.7.16.0
- Severity
- High · CVSS 7.2
- Type
- Remote code execution
CWE-94 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your shopware/core version affected?
Who can exploit CVE-2026-23498
- Access: A high-privilege account in the app, such as an admin.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
How to fix CVE-2026-23498 in shopware/core
- Find the installed version:
composer show shopware/core. If you never required it yourself,composer why shopware/coreshows which package pulls it in. - Update it:
composer update shopware/core --with-all-dependencies. You need 6.7.6.1 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"shopware/core": "^6.7.6.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-23498. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Never pass user-controlled data to unserialize() or to template rendering, and restrict who can edit templates or settings.
- Put a web application firewall in front of the app and watch for new PHP files or admin users.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-23498 advisory
Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.
References
- GitHub advisory GHSA-7cw6-7h3h-v8pf github.com
- Fix commit 3966b05 github.com
Other shopware/core advisories
- medium CVE-2026-48013: Shopware: SSRF in Media External-Link Endpoint Bypasses IP Validation 2026-06-04
- medium CVE-2026-48015: Shopware: Stored XSS via SVG file upload — no SVG sanitization 2026-06-04
- medium CVE-2026-48016: Shopware: Unauthorized Payment Trigger for Foreign Orders via /store-api/handle-payment 2026-06-04
- medium CVE-2026-48014: Shopware: Admin API ACL Bypass in Order State Transition Endpoints 2026-06-04
- medium CVE-2026-48012: Shopware SSO referer trust leading to an arbitrary redirect target 2026-06-04
- low CVE-2026-48011: Shopware: Timing-attack on admin panel allowing enumeration of administrator usernames 2026-06-04
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.