Plugins · yt-player · data as of 2026-11-04
Is Video Player for YouTube safe? Known vulnerabilities and latest version
- Latest version
- 2.1.4
- Last updated
- 2026-10-26
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.1+
A modern, accessible, fully customizable & user-friendly YouTube Video Player for WordPress. — by bPlugins
What to do
- Update to the latest version (2.1.4). Anything older than 2.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yt-player --field=version shows what you run; wp plugin update yt-player updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.8 CVE-2026-85007 · published 2026-10-29
Missing authorization check in Video Player for YouTube (older than 2.1.4)
- Affected
- older than 2.1.4
- Fixed in
- 2.1.4
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Video Player for YouTube WordPress plugin before 2.1.4 does not perform a capability check on its player-preset AJAX handler, allowing users with the Contributor role and above to read the site-wide player-preset configuration, and in versions before 2.1.1 to modify and delete it as well.
medium 6.8 CVE-2026-84937 · published 2026-09-05
SQL injection in Video Player for YouTube (older than 2.1.0)
- Affected
- older than 2.1.0
- Fixed in
- 2.1.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Video Player for YouTube WordPress plugin before 2.1.0 does not properly sanitise and escape user-supplied input before using it in a SQL statement, allowing users with the Contributor role and above to perform SQL injection attacks and read arbitrary data from the database.
medium 5.3 CVE-2026-27422 · published 2026-07-23
Missing authorization check in Video Player for YouTube (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in bPlugins YT Player yt-player allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YT Player: from n/a through 2.1.2.
medium 5.4 CVE-2021-24414 · published 2021-10-25
Cross-site scripting (XSS) in Video Player for YouTube (older than 1.4)
- Affected
- older than 1.4
- Fixed in
- 1.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Video Player for YouTube WordPress plugin before 1.4 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Recent activity
- 2026-10-26 — latest release on wordpress.org (2.1.4).
- 2026-10-29 — Missing authorization check disclosed (CVE-2026-85007), fixed in 2.1.4.
- 2026-09-05 — SQL injection disclosed (CVE-2026-84937), fixed in 2.1.0.
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-27422), fixed in 2.1.3.
Get an email when Video Player for YouTube has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Video Player for YouTube (yt-player) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bPlugins (36 tracked)
Types found in this plugin: Missing authorization (2) · SQL injection (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yt-player (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yt-player"><img src="https://laskyr.com/plugins/yt-player/badge.svg" alt="Video Player for YouTube vulnerability status"></a>