Skip to content
Laskyr

CVE-2026-85007: Video Player for YouTube missing authorization check vulnerability

low 3.8 published 2026-10-29

Fixed in Video Player for YouTube 2.1.4

Video Player for YouTube older than 2.1.4 is affected by this missing authorization issue. Sites on 2.1.4 or newer are not affected; the latest release is 2.1.4.

Affected versions
older than 2.1.4
Fixed in
2.1.4
Latest version
2.1.4
Severity
Low · CVSS 3.8
Active installs
1,000+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update Video Player for YouTube to 2.1.4 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Video Player for YouTube issue. With WP-CLI: wp plugin get yt-player --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Video Player for YouTube WordPress plugin before 2.1.4 does not perform a capability check on its player-preset AJAX handler, allowing users with the Contributor role and above to read the site-wide player-preset configuration, and in versions before 2.1.1 to modify and delete it as well.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-85007.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit