Plugins · yml-for-yandex-market · data as of 2026-11-04
Is YML for Yandex Market safe? Known vulnerabilities and latest version
- Latest version
- 5.12.0
- Last updated
- 2026-10-31
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4.0+
Creates a YML-feed to upload to Yandex Market and not only. — by icopydoc
What to do
- Update to the latest version (5.12.0). Anything older than 5.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yml-for-yandex-market --field=version shows what you run; wp plugin update yml-for-yandex-market updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
medium 6.5 CVE-2025-14545 · published 2026-04-10
Remote code execution in YML for Yandex Market (older than 5.0.26)
- Affected
- older than 5.0.26
- Fixed in
- 5.0.26
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The YML for Yandex Market WordPress plugin before 5.0.26 is vulnerable to Remote Code Execution via the feed generation process.
medium 6.8 CVE-2026-32567 · published 2026-03-25
Path traversal / file read in YML for Yandex Market (not stated by the source)
- Affected
- not stated by the source
- Fixed in
- 5.3.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- not stated · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in icopydoc YML for Yandex Market yml-for-yandex-market allows Path Traversal.This issue affects YML for Yandex Market: from n/a through < 5.3.0.
medium 6.1 CVE-2024-9378 · published 2024-10-02
Reflected cross-site scripting (XSS) in YML for Yandex Market (4.7.2 and older)
- Affected
- 4.7.2 and older
- Fixed in
- 4.7.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The YML for Yandex Market plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'page' parameter in all versions up to, and including, 4.7.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-9378Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-1365 · published 2024-03-13
Reflected cross-site scripting (XSS) in YML for Yandex Market (4.2.3 and older)
- Affected
- 4.2.3 and older
- Fixed in
- 4.2.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The YML for Yandex Market plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the feed_id parameter in all versions up to, and including, 4.2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
medium 6.1 CVE-2023-30473 · published 2023-08-16
Reflected cross-site scripting (XSS) in YML for Yandex Market (3.10.7 and older)
- Affected
- 3.10.7 and older
- Fixed in
- 3.10.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Maxim Glazunov YML for Yandex Market plugin <= 3.10.7 versions.
Recent activity
- 2026-10-31 — latest release on wordpress.org (5.12.0).
- 2026-04-10 — Remote code execution disclosed (CVE-2025-14545), fixed in 5.0.26.
- 2026-03-25 — Path traversal / file read disclosed (CVE-2026-32567), fixed in 5.3.0.
- 2024-10-02 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-9378), fixed in 4.7.3.
Get an email when YML for Yandex Market has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for YML for Yandex Market (yml-for-yandex-market) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by icopydoc (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Remote code execution (1) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yml-for-yandex-market (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yml-for-yandex-market"><img src="https://laskyr.com/plugins/yml-for-yandex-market/badge.svg" alt="YML for Yandex Market vulnerability status"></a>