Skip to content
Laskyr

Plugins · yaycurrency · data as of 2026-11-04

Is YayCurrency safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.5)

As of 2026-11-04. 3 issues are on record for older versions; version 3.3.5 or newer fixes all of them that state a fix.

Latest version
3.3.5
Last updated
2026-08-23
Active installs
7,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.4+

WooCommerce Multi-Currency made easy, powerful, and flexible. — by YayCommerce

What to do

  1. Update to the latest version (3.3.5). Anything older than 3.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yaycurrency --field=version shows what you run; wp plugin update yaycurrency updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-16058 · published 2026-08-19

Missing authorization check in YayCurrency (older than 3.3.5)

Affected
older than 3.3.5
Fixed in
3.3.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The YayCurrency WordPress plugin before 3.3.5 does not perform any capability or ownership check on several of its multi-vendor integration handlers that are reachable by unauthenticated users, allowing anyone to read the store's order totals and its vendors' earnings, balance ledgers, and withdrawal histories by iterating identifiers.

NVD CVE-2026-16058WPScan advisory

high 7.5 CVE-2025-67994 · published 2026-02-20

Missing authorization check in YayCurrency (3.3 and older)

Affected
3.3 and older
Fixed in
3.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in YayCommerce YayCurrency yaycurrency allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YayCurrency: from n/a through <= 3.3.

NVD CVE-2025-67994Patchstack advisory

medium 6.6 CVE-2025-60114 · published 2025-09-26

Remote code execution in YayCurrency (3.3.1 and older)

Affected
3.3.1 and older
Fixed in
3.3.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in YayCommerce YayCurrency yaycurrency allows Code Injection.This issue affects YayCurrency: from n/a through <= 3.3.1.

NVD CVE-2025-60114Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YayCurrency vulnerability status badge
<a href="https://laskyr.com/plugins/yaycurrency"><img src="https://laskyr.com/plugins/yaycurrency/badge.svg" alt="YayCurrency vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit