Skip to content
Laskyr

Plugins · xserver-migrator · data as of 2026-11-04

Is XServer Migrator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.7 or newer fixes all of them that state a fix.

Latest version
1.6.7
Last updated
2026-09-30
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

エックスサーバー株式会社が提供するレンタルサーバーサービスで「WordPress簡単移行機能」をご利用いただくためのプラグインです。 — by XServer

What to do

  1. Update to the latest version (1.6.7). Anything older than 1.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get xserver-migrator --field=version shows what you run; wp plugin update xserver-migrator updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-102387 · published 2026-10-06

Information disclosure in XServer Migrator (1.6.6 and older)

Affected
1.6.6 and older
Fixed in
1.6.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Xserver Migrator <= 1.6.6 versions.

NVD CVE-2026-102387Patchstack advisory

critical 9.6 CVE-2024-33913 · published 2024-05-02

Cross-site request forgery (CSRF) in XServer Migrator (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary File Upload in Xserver Migrator.This issue affects Xserver Migrator: from n/a through 1.6.1.

NVD CVE-2024-33913Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
XServer Migrator vulnerability status badge
<a href="https://laskyr.com/plugins/xserver-migrator"><img src="https://laskyr.com/plugins/xserver-migrator/badge.svg" alt="XServer Migrator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit