Skip to content
Laskyr

CVE-2026-102387: XServer Migrator information disclosure vulnerability

high 7.5 published 2026-10-06

Fixed in XServer Migrator 1.6.7

XServer Migrator 1.6.6 and older is affected by this information disclosure issue. Sites on 1.6.7 or newer are not affected; the latest release is 1.6.7.

Affected versions
1.6.6 and older
Fixed in
1.6.7
Latest version
1.6.7
Severity
High · CVSS 7.5
Active installs
10,000+
Type
Information disclosure

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

What to do now

  1. Update XServer Migrator to 1.6.7 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known XServer Migrator issue. With WP-CLI: wp plugin get xserver-migrator --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated Sensitive Data Exposure in Xserver Migrator <= 1.6.6 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-102387.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit