Skip to content
Laskyr

Plugins · wpmastertoolkit · data as of 2026-11-04

Is WPMasterToolKit (WPMTK) safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.25.0)

As of 2026-11-04. 6 issues are on record for older versions; version 2.23.1 or newer fixes all of them that state a fix.

Latest version
2.25.0
Last updated
2026-09-24
Active installs
5,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Modular WordPress toolkit for security, performance, SMTP, WebP images, code snippets, redirects, administration and more. — by Ludwig You

What to do

  1. Update to the latest version (2.25.0). Anything older than 2.23.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpmastertoolkit --field=version shows what you run; wp plugin update wpmastertoolkit updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-66624 · published 2026-09-17

SQL injection in WPMasterToolKit (WPMTK) (2.22.0 and older)

Affected
2.22.0 and older
Fixed in
2.23.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator SQL Injection in WPMasterToolKit <= 2.22.0 versions.

NVD CVE-2026-66624Patchstack advisory

medium 4.3 CVE-2026-24388 · published 2026-01-22

Missing authorization check in WPMasterToolKit (WPMTK) (2.14.0 and older)

Affected
2.14.0 and older
Fixed in
2.14.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ludwig You WPMasterToolKit wpmastertoolkit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPMasterToolKit: from n/a through <= 2.14.0.

NVD CVE-2026-24388Patchstack advisory

medium 5.3 CVE-2025-14166 · published 2025-12-12

Remote code execution in WPMasterToolKit (WPMTK) (2.13.0 and older)

Affected
2.13.0 and older
Fixed in
2.13.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPMasterToolKit plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 2.13.0. This is due to the plugin allowing Author-level users to create and execute arbitrary PHP code through the Code Snippets feature without proper capability checks. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute arbitrary PHP code on the server, leading to remote code execution, privilege escalation, and complete site compromise.

NVD CVE-2025-14166Wordfence advisoryPlugin source

high 7.2 CVE-2025-3300 · published 2025-04-24

Path traversal / file read in WPMasterToolKit (WPMTK) (1.15.0 and older)

Affected
1.15.0 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPMasterToolKit (WPMTK) – All in one plugin plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.5.2. This makes it possible for authenticated attackers, with Administrator-level access and above, to read and modify the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-3300Wordfence advisoryCode change (fix)wordpress.org

medium 4.9 CVE-2024-56248 · published 2025-01-02

Path traversal / file read in WPMasterToolKit (WPMTK) (1.13.1 and older)

Affected
1.13.1 and older
Fixed in
1.14.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Ludwig You WPMasterToolKit wpmastertoolkit allows Path Traversal.This issue affects WPMasterToolKit: from n/a through <= 1.13.1.

NVD CVE-2024-56248Patchstack advisory

critical 9.1 CVE-2024-56249 · published 2025-01-02

Arbitrary file upload in WPMasterToolKit (WPMTK) (1.13.1 and older)

Affected
1.13.1 and older
Fixed in
1.14.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Ludwig You WPMasterToolKit wpmastertoolkit allows Upload a Web Shell to a Web Server.This issue affects WPMasterToolKit: from n/a through <= 1.13.1.

NVD CVE-2024-56249Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPMasterToolKit (WPMTK) vulnerability status badge
<a href="https://laskyr.com/plugins/wpmastertoolkit"><img src="https://laskyr.com/plugins/wpmastertoolkit/badge.svg" alt="WPMasterToolKit (WPMTK) vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit