Skip to content
Laskyr

Plugins · wpcasa · data as of 2026-11-04

Is WPCasa safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.5)

As of 2026-11-04. 4 issues are on record for older versions; version 1.4.2 or newer fixes all of them that state a fix.

Latest version
1.5.5
Last updated
2026-09-08
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Flexible WordPress plugin to create professional real estate websites and manage property listings with ease, ideal for agents and portals of any size — by WPSight

What to do

  1. Update to the latest version (1.5.5). Anything older than 1.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpcasa --field=version shows what you run; wp plugin update wpcasa updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62043 · published 2026-03-19

Cross-site scripting (XSS) in WPCasa (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in WPSight WPCasa allows DOM-Based XSS.This issue affects WPCasa: from n/a through 1.4.1.

NVD CVE-2025-62043Patchstack advisory

critical 9.8 CVE-2025-9321 · published 2025-09-23

Remote code execution in WPCasa (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPCasa plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 1.4.1. This is due to insufficient input validation and restriction on the 'api_requests' function. This makes it possible for unauthenticated attackers to call arbitrary functions and execute code.

NVD CVE-2025-9321Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-39575 · published 2025-04-16

Stored cross-site scripting (XSS) in WPCasa (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPSight WPCasa wpcasa allows Stored XSS.This issue affects WPCasa: from n/a through <= 1.3.2.

NVD CVE-2025-39575Patchstack advisory

medium 5.3 CVE-2024-53826 · published 2024-12-06

Missing authorization check in WPCasa (1.2.13 and older)

Affected
1.2.13 and older
Fixed in
1.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPSight WPCasa wpcasa allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WPCasa: from n/a through <= 1.2.13.

NVD CVE-2024-53826Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPCasa vulnerability status badge
<a href="https://laskyr.com/plugins/wpcasa"><img src="https://laskyr.com/plugins/wpcasa/badge.svg" alt="WPCasa vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit