Skip to content
Laskyr

Plugins · wp-ultimate-exporter · data as of 2026-11-04

Is Export All Posts, Products, Orders & Users safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1)

As of 2026-11-04. 9 issues are on record for older versions; version 3.1 or newer fixes all of them that state a fix.

Latest version
3.1
Last updated
2026-09-30
Active installs
6,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Export WooCommerce products, orders, users and any WordPress content to CSV, XML, Excel or Google Sheets file. Bulk export posts, pages, custom post t … — by Smackcoders Inc.,

What to do

  1. Update to the latest version (3.1). Anything older than 3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-ultimate-exporter --field=version shows what you run; wp plugin update wp-ultimate-exporter updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-103348 · published 2026-10-05

PHP object injection in Export All Posts, Products, Orders & Users (3.0 and older)

Affected
3.0 and older
Fixed in
3.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Smackcoders Inc. WP Ultimate Exporter wp-ultimate-exporter allows Object Injection.This issue affects WP Ultimate Exporter: from n/a through 3.0.

NVD CVE-2026-103348Patchstack advisory

critical 9.8 CVE-2025-2332 · published 2025-03-27

PHP object injection in Export All Posts, Products, Orders & Users (2.13 and older)

Affected
2.13 and older
Fixed in
2.14 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Export All Posts, Products, Orders, Refunds & Users plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.13 via deserialization of untrusted input in the 'returnMetaValueAsCustomerInput' function. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2025-2332Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-12315 · published 2025-02-12

Information disclosure in Export All Posts, Products, Orders & Users (2.9.3 and older)

Affected
2.9.3 and older
Fixed in
2.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Export All Posts, Products, Orders, Refunds & Users plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.9.3 via the exports directory. This makes it possible for unauthenticated attackers to extract sensitive data stored insecurely in the /wp-content/uploads/smack_uci_uploads/exports/ directory which can contain information like exported user data.

NVD CVE-2024-12315Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2025-24611 · published 2025-01-24

Path traversal / file read in Export All Posts, Products, Orders & Users (2.9 and older)

Affected
2.9 and older
Fixed in
2.9.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Smackcoders Inc., WP Ultimate Exporter wp-ultimate-exporter allows Absolute Path Traversal.This issue affects WP Ultimate Exporter: from n/a through <= 2.9.

NVD CVE-2025-24611Patchstack advisory

critical 9.1 CVE-2024-56278 · published 2025-01-07

Remote code execution in Export All Posts, Products, Orders & Users (2.9.1 and older)

Affected
2.9.1 and older
Fixed in
2.9.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Smackcoders Inc., WP Ultimate Exporter wp-ultimate-exporter allows PHP Remote File Inclusion.This issue affects WP Ultimate Exporter: from n/a through <= 2.9.1.

NVD CVE-2024-56278Patchstack advisory

high 7.5 CVE-2023-2487 · published 2023-12-21

Information disclosure in Export All Posts, Products, Orders & Users (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Smackcoders Export All Posts, Products, Orders, Refunds & Users.This issue affects Export All Posts, Products, Orders, Refunds & Users: from n/a through 2.4.1.

NVD CVE-2023-2487Patchstack advisory

high 7.5 CVE-2023-45066 · published 2023-11-30

Information disclosure in Export All Posts, Products, Orders & Users (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Smackcoders Export All Posts, Products, Orders, Refunds & Users.This issue affects Export All Posts, Products, Orders, Refunds & Users: from n/a through 2.4.1.

NVD CVE-2023-45066Patchstack advisory

critical 9.8 CVE-2016-11000 · published 2019-09-20

SQL injection in Export All Posts, Products, Orders & Users (1.1 and older)

Affected
1.1 and older
Fixed in
1.1.1 *
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The wp-ultimate-exporter plugin through 1.1 for WordPress has SQL injection via the export_type_name parameter.

NVD CVE-2016-11000wordpress.orgseclists.org

high 8.8 CVE-2018-20968 · published 2019-08-14

Cross-site request forgery (CSRF) in Export All Posts, Products, Orders & Users (older than 1.4.2)

Affected
older than 1.4.2
Fixed in
1.4.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The wp-ultimate-exporter plugin before 1.4.2 for WordPress has CSRF.

NVD CVE-2018-20968wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Export All Posts, Products, Orders & Users vulnerability status badge
<a href="https://laskyr.com/plugins/wp-ultimate-exporter"><img src="https://laskyr.com/plugins/wp-ultimate-exporter/badge.svg" alt="Export All Posts, Products, Orders & Users vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit