Skip to content
Laskyr

Plugins · wp-ticket · data as of 2026-11-04

Is Customer Support Ticket System & Helpdesk safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.0.6)

As of 2026-11-04. 4 issues are on record for older versions; version 6.0.6 or newer fixes all of them that state a fix.

Latest version
6.0.6
Last updated
2026-07-21
Active installs
400+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8

Let customers submit tickets, assign agents, set priorities, track status, and get instant email notifications. All from your website. — by emarket-design

What to do

  1. Update to the latest version (6.0.6). Anything older than 6.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-ticket --field=version shows what you run; wp plugin update wp-ticket updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-15011 · published 2026-07-23

Remote code execution in Customer Support Ticket System & Helpdesk (6.0.5 and older)

Affected
6.0.5 and older
Fixed in
6.0.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Customer Support Ticket System & Helpdesk plugin for WordPress is vulnerable to Code Injection via the 'path' parameter in all versions up to, and including, 6.0.5 due to the use of dynamic function invocation on an attacker-controlled value with insufficient validation. This makes it possible for unauthenticated attackers to invoke arbitrary parameterless PHP functions, which can be used to disrupt site functionality or expose sensitive information. The required nonce is publicly emitted via wp_localize_script whenever the plugin's [emd_form] shortcode is rendered on any public-facing page, making the endpoint reachable by unauthenticated visitors without any prior authentication or privilege.

NVD CVE-2026-15011Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-9848 · published 2026-06-13

SQL injection in Customer Support Ticket System & Helpdesk (6.0.4 and older)

Affected
6.0.4 and older
Fixed in
6.0.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Ticket plugin for WordPress is vulnerable to SQL Injection via the WordPress search query parameter (`s`) in versions up to, and including, 6.0.4 The plugin hooks WordPress's `posts_request` filter with `wp_ticket_com_posts_request()`, which calls `emd_author_search_results()` when the current request is an unauthenticated front-end search. That function reads `$query->query_vars['s']` — already wp_unslash()'d by `WP_Query::parse_query()`, so wp_magic_quotes protection has been stripped — and concatenates the raw value into a SQL `LIKE` clause inside a UNION sub-SELECT appended to the main query, with no `$wpdb->prepare()` or escaping. This makes it possible for unauthenticated attackers to append additional SQL queries into already-existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-9848Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-60157 · published 2025-09-26

Stored cross-site scripting (XSS) in Customer Support Ticket System & Helpdesk (6.0.2 and older)

Affected
6.0.2 and older
Fixed in
6.0.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in emarket-design WP Ticket Customer Service Software & Support Ticket System wp-ticket allows Stored XSS.This issue affects WP Ticket Customer Service Software & Support Ticket System: from n/a through <= 6.0.2.

NVD CVE-2025-60157Patchstack advisory

high 8.1 CVE-2025-53584 · published 2025-08-28

PHP object injection in Customer Support Ticket System & Helpdesk (6.0.2 and older)

Affected
6.0.2 and older
Fixed in
6.0.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in emarket-design WP Ticket Customer Service Software & Support Ticket System wp-ticket allows Object Injection.This issue affects WP Ticket Customer Service Software & Support Ticket System: from n/a through <= 6.0.2.

NVD CVE-2025-53584Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Customer Support Ticket System & Helpdesk vulnerability status badge
<a href="https://laskyr.com/plugins/wp-ticket"><img src="https://laskyr.com/plugins/wp-ticket/badge.svg" alt="Customer Support Ticket System & Helpdesk vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit