Skip to content
Laskyr

Plugins · wp-spell-check · data as of 2026-11-04

Is WP Spell Check safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (12.2)

As of 2026-11-04. 5 issues are on record for older versions; version 12.2 or newer fixes all of them that state a fix.

Latest version
12.2
Last updated
2026-09-28
Active installs
2,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Proofread & Audit your WordPress website with One Click! Find & fix the errors and build a professional image for your business. — by WP Spell Check

What to do

  1. Update to the latest version (12.2). Anything older than 12.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-spell-check --field=version shows what you run; wp plugin update wp-spell-check updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-100506 · published 2026-10-05

PHP object injection in WP Spell Check (12.1 and older)

Affected
12.1 and older
Fixed in
12.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in WP Spell Check WP Spell Check wp-spell-check allows Object Injection.This issue affects WP Spell Check: from n/a through 12.1.

NVD CVE-2026-100506Patchstack advisory

medium 5.4 CVE-2025-25111 · published 2025-02-07

Cross-site request forgery (CSRF) in WP Spell Check (9.21 and older)

Affected
9.21 and older
Fixed in
9.22
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WP Spell Check WP Spell Check wp-spell-check allows Cross Site Request Forgery.This issue affects WP Spell Check: from n/a through <= 9.21.

NVD CVE-2025-25111Patchstack advisory

high 8.8 CVE-2024-22143 · published 2024-01-31

Cross-site request forgery (CSRF) in WP Spell Check (9.17 and older)

Affected
9.17 and older
Fixed in
9.18
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WP Spell Check.This issue affects WP Spell Check: from n/a through 9.17.

NVD CVE-2024-22143Patchstack advisory

medium 4.8 CVE-2022-2658 · published 2023-01-16

Stored cross-site scripting (XSS) in WP Spell Check (older than 9.13)

Affected
older than 9.13
Fixed in
9.13
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Spell Check WordPress plugin before 9.13 does not escape ignored words, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2022-2658WPScan advisory

high 8.8 CVE-2019-6027 · published 2019-12-26

Cross-site request forgery (CSRF) in WP Spell Check (7.1.9 and older)

Affected
7.1.9 and older
Fixed in
9.22 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site request forgery (CSRF) vulnerability in WP Spell Check 7.1.9 and earlier allows remote attackers to hijack the authentication of administrators via unspecified vectors.

NVD CVE-2019-6027wordpress.orgjvn.jp

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Spell Check vulnerability status badge
<a href="https://laskyr.com/plugins/wp-spell-check"><img src="https://laskyr.com/plugins/wp-spell-check/badge.svg" alt="WP Spell Check vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit