Skip to content
Laskyr

CVE-2026-100506: WP Spell Check PHP object injection vulnerability

high 7.2 published 2026-10-05 · updated 2026-10-06

Fixed in WP Spell Check 12.2

WP Spell Check 12.1 and older is affected by this PHP object injection issue. Sites on 12.2 or newer are not affected; the latest release is 12.2.

Affected versions
12.1 and older
Fixed in
12.2
Latest version
12.2
Severity
High · CVSS 7.2
Active installs
2,000+
Type
PHP object injection

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update WP Spell Check to 12.2 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WP Spell Check issue. With WP-CLI: wp plugin get wp-spell-check --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Deserialization of Untrusted Data vulnerability in WP Spell Check WP Spell Check wp-spell-check allows Object Injection.This issue affects WP Spell Check: from n/a through 12.1.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-100506.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit