Skip to content
Laskyr

Plugins · wp-product-feed-manager · data as of 2026-11-04

Is WPMR Google Feed Manager for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.24.1)

As of 2026-11-04. 4 issues are on record for older versions; version 2.23.8 or newer fixes all of them that state a fix.

Latest version
2.24.1
Last updated
2026-10-26
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The WooCommerce product feed plugin built for Google. UNLIMITED products & feeds, completely free. Create your Google Merchant feed in 5 minutes. — by aukemarketing

What to do

  1. Update to the latest version (2.24.1). Anything older than 2.23.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-product-feed-manager --field=version shows what you run; wp plugin update wp-product-feed-manager updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-19778 · published 2026-09-09

SQL injection in WPMR Google Feed Manager for WooCommerce (2.23.7 and older)

Affected
2.23.7 and older
Fixed in
2.23.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPMR Google Feed Manager for WooCommerce – Sell on Google Merchant Center & Shopping plugin for WordPress is vulnerable to time-based SQL Injection via the 'feed' parameter in all versions up to, and including, 2.23.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-19778Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-7258 · published 2024-08-23

Remote code execution in WPMR Google Feed Manager for WooCommerce (2.8.0 and older)

Affected
2.8.0 and older
Fixed in
2.9.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WooCommerce Google Feed Manager plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'wppfm_removeFeedFile' function in all versions up to, and including, 2.8.0. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2024-7258Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2024-3067 · published 2024-04-16

SQL injection in WPMR Google Feed Manager for WooCommerce (2.4.2 and older)

Affected
2.4.2 and older
Fixed in
2.5.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Google Feed Manager plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 2.4.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This can also be used by unauthenticated attackers to inject malicious web scripts.

NVD CVE-2024-3067Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2024-29112 · published 2024-03-19

Stored cross-site scripting (XSS) in WPMR Google Feed Manager for WooCommerce (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.3.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Marketing Robot WooCommerce Google Feed Manager allows Stored XSS.This issue affects WooCommerce Google Feed Manager: from n/a through 2.2.0.

NVD CVE-2024-29112Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPMR Google Feed Manager for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/wp-product-feed-manager"><img src="https://laskyr.com/plugins/wp-product-feed-manager/badge.svg" alt="WPMR Google Feed Manager for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit