Skip to content
Laskyr

Plugins · wp-mail-log · data as of 2026-11-04

Is WP Mail Log safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.6)

As of 2026-11-04. 9 issues are on record for older versions; version 1.1.3 or newer fixes all of them that state a fix.

Latest version
1.1.6
Last updated
2026-06-30
Active installs
10,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

WP Mail Log helps you to Log and view all emails from WordPress. It is useful if you have to debug email related problems or have to store sent emails … — by WPVibes

What to do

  1. Update to the latest version (1.1.6). Anything older than 1.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-mail-log --field=version shows what you run; wp plugin update wp-mail-log updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2023-33999 · published 2026-06-11

Cross-site scripting (XSS) in WP Mail Log (1.0.2 and older)

Affected
1.0.2 and older
Fixed in
1.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in WPVibes WP Mail Log allows DOM-Based XSS. This issue affects WP Mail Log: from n/a through 1.0.2.

NVD CVE-2023-33999Patchstack advisory

high 8.8 CVE-2023-51410 · published 2023-12-29

Arbitrary file upload in WP Mail Log (1.1.2 and older)

Affected
1.1.2 and older
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WPVibes WP Mail Log.This issue affects WP Mail Log: from n/a through 1.1.2.

NVD CVE-2023-51410Patchstack advisory

high 8.8 CVE-2023-5674 · published 2023-12-26

SQL injection in WP Mail Log (older than 1.1.3)

Affected
older than 1.1.3
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log WordPress plugin before 1.1.3 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as Contributor.

NVD CVE-2023-5674WPScan advisory

high 7.6 CVE-2023-5644 · published 2023-12-26

Missing authorization check in WP Mail Log (older than 1.1.3)

Affected
older than 1.1.3
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log WordPress plugin before 1.1.3 does not correctly authorize its REST API endpoints, allowing users with the Contributor role to view and delete data that should only be accessible to Admin users.

NVD CVE-2023-5644WPScan advisory

high 8.8 CVE-2023-5645 · published 2023-12-26

SQL injection in WP Mail Log (older than 1.1.3)

Affected
older than 1.1.3
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log WordPress plugin before 1.1.3 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as Contributor.

NVD CVE-2023-5645WPScan advisory

medium 6.5 CVE-2023-5672 · published 2023-12-26

File inclusion in WP Mail Log (older than 1.1.3)

Affected
older than 1.1.3
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log WordPress plugin before 1.1.3 does not properly validate file path parameters when attaching files to emails, leading to local file inclusion, and allowing an attacker to leak the contents of arbitrary files.

NVD CVE-2023-5672WPScan advisory

high 8.8 CVE-2023-5673 · published 2023-12-26

Remote code execution in WP Mail Log (older than 1.1.3)

Affected
older than 1.1.3
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log WordPress plugin before 1.1.3 does not properly validate file extensions uploading files to attach to emails, allowing attackers to upload PHP files, leading to remote code execution.

NVD CVE-2023-5673WPScan advisory

medium 6.1 CVE-2023-3088 · published 2023-07-12

Stored cross-site scripting (XSS) in WP Mail Log (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Mail Log plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 1.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-3088Wordfence advisoryCode change (fix)

high 8.8 CVE-2022-45807 · published 2023-02-02

Cross-site request forgery (CSRF) in WP Mail Log (1.0.1 and older)

Affected
1.0.1 and older
Fixed in
1.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) in WPVibes WP Mail Log plugin <= 1.0.1 versions.

NVD CVE-2022-45807Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Mail Log vulnerability status badge
<a href="https://laskyr.com/plugins/wp-mail-log"><img src="https://laskyr.com/plugins/wp-mail-log/badge.svg" alt="WP Mail Log vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit