Plugins · wp-latest-posts · data as of 2026-11-04
Is WP Latest Posts safe? Known vulnerabilities and latest version
- Status
- Closed 2026-06-17
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate wp-latest-posts && wp plugin delete wp-latest-posts
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
medium 6.4 CVE-2026-9620 · published 2026-06-24
Stored cross-site scripting (XSS) in WP Latest Posts (5.0.11 and older)
- Affected
- 5.0.11 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Latest Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via crafted image src attributes in post content in versions up to, and including, 5.0.11. This is due to insufficient output escaping in the field() and loop() functions, which extract the raw src attribute value from <img> tags within post_content using a regular expression and then reconstruct new <img> elements or CSS background-image declarations by directly concatenating the unescaped value — bypassing WordPress's kses filtering entirely. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2024-4135 · published 2024-05-08
Remote code execution in WP Latest Posts (5.0.7 and older)
- Affected
- 5.0.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Latest Posts plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the plugin allowing users to execute an action that does not properly validate a user-supplied value prior to using that value in a call to do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
medium 6.1 CVE-2016-10913 · published 2019-08-20
Cross-site scripting (XSS) in WP Latest Posts (older than 3.7.5)
- Affected
- older than 3.7.5
- Fixed in
- 3.7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The wp-latest-posts plugin before 3.7.5 for WordPress has XSS.
Recent activity
- 2026-06-17 — closed on wordpress.org (Author Request).
- 2026-06-24 — Stored cross-site scripting (XSS) disclosed (CVE-2026-9620), fix version not stated.
- 2024-05-08 — Remote code execution disclosed (CVE-2024-4135), fix version not stated.
- 2019-08-20 — Cross-site scripting (XSS) disclosed (CVE-2016-10913), fixed in 3.7.5.
Get an email when WP Latest Posts has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Latest Posts (wp-latest-posts) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Remote code execution (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/wp-latest-posts (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-latest-posts"><img src="https://laskyr.com/plugins/wp-latest-posts/badge.svg" alt="WP Latest Posts vulnerability status"></a>